aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/lib.mk
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-01-28 12:01:51 +0000
committerJohn Crispin <blogic@openwrt.org>2015-01-28 12:01:51 +0000
commitdb5b2e531909ad989b2f8dc0e2690bca46e57f49 (patch)
tree386443e39314f09ed3f3035e8d4de9d5f294dd20 /package/kernel/linux/modules/lib.mk
parent16cf695f5e6ce357d7054d16042a161652236d43 (diff)
downloadupstream-db5b2e531909ad989b2f8dc0e2690bca46e57f49.tar.gz
upstream-db5b2e531909ad989b2f8dc0e2690bca46e57f49.tar.bz2
upstream-db5b2e531909ad989b2f8dc0e2690bca46e57f49.zip
kernel: add support for NFSv4
To: openwrt-devel@lists.openwrt.org This work is based on Daniel Colascione's submission to the OpenWrt devel mailing list on January 15th, 2014. I modified his patch so that it applied to the current OpenWrt Barrier Breaker tree. Signed-off-by: W. Michael Petullo <mike@flyn.org> git-svn-id: svn://svn.openwrt.org/openwrt/branches/barrier_breaker@44162 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/lib.mk')
-rw-r--r--package/kernel/linux/modules/lib.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/lib.mk b/package/kernel/linux/modules/lib.mk
index cd919ba62e..a148da36ed 100644
--- a/package/kernel/linux/modules/lib.mk
+++ b/package/kernel/linux/modules/lib.mk
@@ -202,3 +202,18 @@ define KernelPackage/lib-cordic/description
endef
$(eval $(call KernelPackage,lib-cordic))
+
+
+define KernelPackage/lib-oid-registry
+ SUBMENU:=$(LIB_MENU)
+ TITLE:=OID-Registry function support
+ KCONFIG:=CONFIG_OID_REGISTRY
+ FILES:=$(LINUX_DIR)/lib/oid_registry.ko
+ AUTOLOAD:=$(call AutoProbe,oid-registry)
+endef
+
+define KernelPackage/lib-oid-registry/description
+ Kernel module for OID-Registry function support
+endef
+
+$(eval $(call KernelPackage,lib-oid-registry))