aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/input.mk
diff options
context:
space:
mode:
authorLech Perczak <lech.perczak@gmail.com>2022-04-28 23:34:23 +0200
committerPiotr Dymacz <pepe2k@gmail.com>2022-07-11 14:14:01 +0200
commit3750acb28a5961d97415a7ccf9fd694f5fd60030 (patch)
tree0f1636c7aabc99268eaf304f4db2446ad1026f2b /package/kernel/linux/modules/input.mk
parent0b7e8f44addaaeb53cef7de9aeea6dc67840ef39 (diff)
downloadupstream-3750acb28a5961d97415a7ccf9fd694f5fd60030.tar.gz
upstream-3750acb28a5961d97415a7ccf9fd694f5fd60030.tar.bz2
upstream-3750acb28a5961d97415a7ccf9fd694f5fd60030.zip
kernel: add kmod-touchscreen-edt-ft5x06 package
This module contains driver for touchscreen used in TechNexion PICO-PI-IMX7D board. Signed-off-by: Lech Perczak <lech.perczak@gmail.com>
Diffstat (limited to 'package/kernel/linux/modules/input.mk')
-rw-r--r--package/kernel/linux/modules/input.mk21
1 files changed, 21 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/input.mk b/package/kernel/linux/modules/input.mk
index e052a7afac..7f042e8535 100644
--- a/package/kernel/linux/modules/input.mk
+++ b/package/kernel/linux/modules/input.mk
@@ -193,6 +193,27 @@ endef
$(eval $(call KernelPackage,input-touchscreen-ads7846))
+define KernelPackage/input-touchscreen-edt-ft5x06
+ SUBMENU:=$(INPUT_MODULES_MENU)
+ TITLE:=EDT FT5x06 and Focaltech FT6236 based touchscreens
+ DEPENDS:=+kmod-i2c-core +kmod-input-core
+ KCONFIG:= \
+ CONFIG_INPUT_TOUCHSCREEN=y \
+ CONFIG_TOUCHSCREEN_PROPERTIES=y@lt5.13 \
+ CONFIG_TOUCHSCREEN_EDT_FT5X06
+ FILES:=$(LINUX_DIR)/drivers/input/touchscreen/edt-ft5x06.ko \
+ $(LINUX_DIR)/drivers/input/touchscreen/of_touchscreen.ko@lt5.13
+ AUTOLOAD:=$(call AutoProbe,edt-ft5x06)
+endef
+
+define KernelPackage/input-touchscreen-edt-ft5x06/description
+ Kernel module for EDT FT5206, FT5306, FT5406, FT5506, Evervision FT5726 \
+ and Focaltech FT6236 based touchscreens
+endef
+
+$(eval $(call KernelPackage,input-touchscreen-edt-ft5x06))
+
+
define KernelPackage/keyboard-imx
SUBMENU:=$(INPUT_MODULES_MENU)
TITLE:=IMX keypad support