aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/input.mk
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2022-08-12 11:02:44 +0200
committerDaniel Golle <daniel@makrotopia.org>2022-08-12 11:05:53 +0200
commit1291a682f855f6d8814134771f9923f4f80b524f (patch)
tree6c518bc360152129ffb4522d9dd19b52f205a152 /package/kernel/linux/modules/input.mk
parent2239ead6eb63933d80e0c26dd95ba684fdd74006 (diff)
downloadupstream-1291a682f855f6d8814134771f9923f4f80b524f.tar.gz
upstream-1291a682f855f6d8814134771f9923f4f80b524f.tar.bz2
upstream-1291a682f855f6d8814134771f9923f4f80b524f.zip
kernel: kmod-input-gpio-keys-polled depends on kmod-input-core
While kmod-input-core was previously indirectly selected by kmod-input-polldev, this is now only the case on Linux 5.10. Select kmod-input-core as dependency independently of the kernel version to fix build error: Package kmod-input-gpio-keys-polled is missing dependencies for the following libraries: input-core.ko Fixes: 54878fbbdd ("kernel: kmod-input-polldev: Depend on kernel 5.10") Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'package/kernel/linux/modules/input.mk')
-rw-r--r--package/kernel/linux/modules/input.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/input.mk b/package/kernel/linux/modules/input.mk
index b0ab3360cc..6270cdeb3b 100644
--- a/package/kernel/linux/modules/input.mk
+++ b/package/kernel/linux/modules/input.mk
@@ -92,7 +92,7 @@ $(eval $(call KernelPackage,input-gpio-keys))
define KernelPackage/input-gpio-keys-polled
SUBMENU:=$(INPUT_MODULES_MENU)
TITLE:=Polled GPIO key support
- DEPENDS:=@GPIO_SUPPORT +LINUX_5_10:kmod-input-polldev
+ DEPENDS:=@GPIO_SUPPORT +kmod-input-core +LINUX_5_10:kmod-input-polldev
KCONFIG:= \
CONFIG_KEYBOARD_GPIO_POLLED \
CONFIG_INPUT_KEYBOARD=y