aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/fs.mk
diff options
context:
space:
mode:
authorAnsuel Smith <ansuelsmth@gmail.com>2021-11-04 21:59:09 +0100
committerDaniel Golle <daniel@makrotopia.org>2022-03-27 02:17:24 +0100
commitbd0db6017b1921c935785cdccdf0243fddf0b949 (patch)
tree692a9e678f7b97b0ee6cf8ccc5021fbcaba15b24 /package/kernel/linux/modules/fs.mk
parentb268ec5ff8baed74037d04a74f61c0417d931ad9 (diff)
downloadupstream-bd0db6017b1921c935785cdccdf0243fddf0b949.tar.gz
upstream-bd0db6017b1921c935785cdccdf0243fddf0b949.tar.bz2
upstream-bd0db6017b1921c935785cdccdf0243fddf0b949.zip
kernel: 5.15: add new module
Add new module require in 5.15 - Changes in block module - Changes in netfilter module (log module unified) - Changes in fs module (mainly new depends for cifs and new ntfs3 module) - Changes in lib add shared lib now used by more than 1 kmod - Changes in crypto, dropped one crypto algo added arm crypto accellerator - Changes in other, add zram default compressor choice and missing lib by tpm module Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com>
Diffstat (limited to 'package/kernel/linux/modules/fs.mk')
-rw-r--r--package/kernel/linux/modules/fs.mk43
1 files changed, 38 insertions, 5 deletions
diff --git a/package/kernel/linux/modules/fs.mk b/package/kernel/linux/modules/fs.mk
index 91cf1ea233..e580a94c60 100644
--- a/package/kernel/linux/modules/fs.mk
+++ b/package/kernel/linux/modules/fs.mk
@@ -87,24 +87,31 @@ define KernelPackage/fs-cifs
SUBMENU:=$(FS_MENU)
TITLE:=CIFS support
KCONFIG:= \
+ CONFIG_SMBFS_COMMON@ge5.15 \
CONFIG_CIFS \
CONFIG_CIFS_DFS_UPCALL=n \
CONFIG_CIFS_UPCALL=n
- FILES:=$(LINUX_DIR)/fs/cifs/cifs.ko
+ FILES:= \
+ $(LINUX_DIR)/fs/smbfs_common/cifs_arc4.ko@ge5.15 \
+ $(LINUX_DIR)/fs/smbfs_common/cifs_md4.ko@ge5.15 \
+ $(LINUX_DIR)/fs/cifs/cifs.ko
AUTOLOAD:=$(call AutoLoad,30,cifs)
$(call AddDepends/nls)
DEPENDS+= \
- +kmod-crypto-md4 \
+ +(LINUX_5_4||LINUX_5_10):kmod-crypto-md4\
+kmod-crypto-md5 \
+kmod-crypto-sha256 \
+kmod-crypto-sha512 \
+kmod-crypto-cmac \
+kmod-crypto-hmac \
- +kmod-crypto-arc4 \
+ +(LINUX_5_4||LINUX_5_10):kmod-crypto-arc4 \
+kmod-crypto-aead \
+kmod-crypto-ccm \
+kmod-crypto-ecb \
- +kmod-crypto-des
+ +kmod-crypto-des \
+ +(LINUX_5_15):kmod-asn1-decoder \
+ +(LINUX_5_15):kmod-oid-registry \
+ +(LINUX_5_15):kmod-dnsresolver
endef
define KernelPackage/fs-cifs/description
@@ -239,10 +246,21 @@ endef
$(eval $(call KernelPackage,fs-f2fs))
+define KernelPackage/fs-netfs
+ SUBMENU:=$(FS_MENU)
+ TITLE:=Network Filesystems support
+ DEPENDS:=@LINUX_5_15
+ KCONFIG:= CONFIG_NETFS_SUPPORT
+ FILES:=$(LINUX_DIR)/fs/netfs/netfs.ko
+ AUTOLOAD:=$(call AutoLoad,28,netfs)
+endef
+
+$(eval $(call KernelPackage,fs-netfs))
+
define KernelPackage/fs-fscache
SUBMENU:=$(FS_MENU)
TITLE:=General filesystem local cache manager
- DEPENDS:=
+ DEPENDS:=+kmod-fs-netfs
KCONFIG:=\
CONFIG_FSCACHE=m \
CONFIG_FSCACHE_STATS=y \
@@ -616,3 +634,18 @@ define KernelPackage/fuse/description
endef
$(eval $(call KernelPackage,fuse))
+
+
+define KernelPackage/fs-ntfs3
+ SUBMENU:=$(FS_MENU)
+ TITLE:=Ntfs3 support
+ KCONFIG:= CONFIG_NTFS3_FS CONFIG_NTFS3_FS_POSIX_ACL=y
+ FILES:=$(LINUX_DIR)/fs/ntfs3/ntfs3.ko
+ AUTOLOAD:=$(call AutoLoad,80,ntfs3)
+endef
+
+define KernelPackage/fuse/description
+ Kernel module for new NTFS3 filesystem support
+endef
+
+$(eval $(call KernelPackage,fs-ntfs3))