aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/fs.mk
diff options
context:
space:
mode:
authorZoltan Herpai <wigyori@uid0.hu>2014-04-28 19:47:38 +0000
committerZoltan Herpai <wigyori@uid0.hu>2014-04-28 19:47:38 +0000
commitaa425b88a81f886c20f8572ea6ac50387c17b94a (patch)
treea0f98e77e3b50f892510dcc0a7ef2ca6b7d62db1 /package/kernel/linux/modules/fs.mk
parent5c91b4020b626d76d8932e022976f4381d77ff16 (diff)
downloadupstream-aa425b88a81f886c20f8572ea6ac50387c17b94a.tar.gz
upstream-aa425b88a81f886c20f8572ea6ac50387c17b94a.tar.bz2
upstream-aa425b88a81f886c20f8572ea6ac50387c17b94a.zip
fs: add kernel modules for AFS client
- add/separate crypto modules - add fscache support - add rxrpc module which is required for AFS - add afs module Signed-Off-By: Nathaniel Wesley Filardo <8S9K8UGO5JGPI3U067229BBACKMQIGVH@cmx.ietfng.org> Acked-by: Zoltan HERPAI <wigyori@uid0.hu> SVN-Revision: 40587
Diffstat (limited to 'package/kernel/linux/modules/fs.mk')
-rw-r--r--package/kernel/linux/modules/fs.mk37
1 files changed, 37 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/fs.mk b/package/kernel/linux/modules/fs.mk
index cd27e4aa6b..5faaf3777c 100644
--- a/package/kernel/linux/modules/fs.mk
+++ b/package/kernel/linux/modules/fs.mk
@@ -7,6 +7,43 @@
FS_MENU:=Filesystems
+define KernelPackage/fs-fscache
+ SUBMENU:=$(FS_MENU)
+ TITLE:=General filesystem local cache manager
+ DEPENDS:=
+ KCONFIG:=\
+ CONFIG_FSCACHE=m \
+ CONFIG_FSCACHE_STATS=y \
+ CONFIG_FSCACHE_HISTOGRAM=n \
+ CONFIG_FSCACHE_DEBUG=n \
+ CONFIG_FSCACHE_OBJECT_LIST=n \
+ CONFIG_CACHEFILES=y \
+ CONFIG_CACHEFILES_DEBUG=n \
+ CONFIG_CACHEFILES_HISTOGRAM=n
+ FILES:=$(LINUX_DIR)/fs/fscache/fscache.ko
+ AUTOLOAD:=$(call AutoLoad,29,fscache)
+endef
+
+$(eval $(call KernelPackage,fs-fscache))
+
+define KernelPackage/fs-afs
+ SUBMENU:=$(FS_MENU)
+ TITLE:=Andrew FileSystem client
+ DEPENDS:=+kmod-rxrpc +kmod-dnsresolver +kmod-fs-fscache
+ KCONFIG:=\
+ CONFIG_AFS_FS=m \
+ CONFIG_AFS_DEBUG=n \
+ CONFIG_AFS_FSCACHE=y
+ FILES:=$(LINUX_DIR)/fs/afs/kafs.ko
+ AUTOLOAD:=$(call AutoLoad,30,kafs)
+endef
+
+define KernelPackage/fs-afs/description
+ Kernel module for Andrew FileSystem client support
+endef
+
+$(eval $(call KernelPackage,fs-afs))
+
define KernelPackage/fs-autofs4
SUBMENU:=$(FS_MENU)
TITLE:=AUTOFS4 filesystem support