aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/fs.mk
diff options
context:
space:
mode:
authorDaniel Dickinson <lede@daniel.thecshore.com>2016-05-18 04:59:15 -0400
committerJohn Crispin <john@phrozen.org>2016-06-30 22:48:39 +0200
commit3ee278c5c937d9983559adc56692144890950a77 (patch)
treed414915186e5c2872f067c2fd2076f0bd9eeb661 /package/kernel/linux/modules/fs.mk
parentd635ef50c5cb9aaca718b6418feea378b450c3a8 (diff)
downloadupstream-3ee278c5c937d9983559adc56692144890950a77.tar.gz
upstream-3ee278c5c937d9983559adc56692144890950a77.tar.bz2
upstream-3ee278c5c937d9983559adc56692144890950a77.zip
package/kernel: Enable XATTR by default
OpenWrt enables XATTR support pretty much universally, therefore for filesystems that a loaded as modules also enable XATTR support so that there are no unexpected missing capabilities. Signed-off-by: Daniel Dickinson <lede@daniel.thecshore.com>
Diffstat (limited to 'package/kernel/linux/modules/fs.mk')
-rw-r--r--package/kernel/linux/modules/fs.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/fs.mk b/package/kernel/linux/modules/fs.mk
index a47eea909d..52fa47a68b 100644
--- a/package/kernel/linux/modules/fs.mk
+++ b/package/kernel/linux/modules/fs.mk
@@ -85,6 +85,7 @@ define KernelPackage/fs-cifs
TITLE:=CIFS support
KCONFIG:= \
CONFIG_CIFS \
+ CONFIG_CIFS_XATTR=y \
CONFIG_CIFS_DFS_UPCALL=n \
CONFIG_CIFS_UPCALL=n
FILES:=$(LINUX_DIR)/fs/cifs/cifs.ko
@@ -387,7 +388,8 @@ $(eval $(call KernelPackage,fs-ntfs))
define KernelPackage/fs-reiserfs
SUBMENU:=$(FS_MENU)
TITLE:=ReiserFS filesystem support
- KCONFIG:=CONFIG_REISERFS_FS
+ KCONFIG:=CONFIG_REISERFS_FS \
+ CONFIG_REISERFS_FS_XATTR=y
FILES:=$(LINUX_DIR)/fs/reiserfs/reiserfs.ko
AUTOLOAD:=$(call AutoLoad,30,reiserfs,1)
endef