aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/fs.mk
diff options
context:
space:
mode:
authorDaniel Dickinson <lede@cshore.thecshore.com>2016-09-29 04:15:46 -0400
committerJohn Crispin <john@phrozen.org>2016-10-04 11:50:48 +0200
commitd0f17fe68240f0f517267741fa76f64eb32f2195 (patch)
tree3d68243de09a495491734f9076178d6f61a3cdb7 /package/kernel/linux/modules/fs.mk
parent1fff7f2dbce978bd95156c69ff3fa1db8578e535 (diff)
downloadupstream-d0f17fe68240f0f517267741fa76f64eb32f2195.tar.gz
upstream-d0f17fe68240f0f517267741fa76f64eb32f2195.tar.bz2
upstream-d0f17fe68240f0f517267741fa76f64eb32f2195.zip
linux/modules/fs: Fix missing vfat dependencies
vfat filesystem fails to mount due to missing codepages with factory-formatted flash drives. Depend on cp437 iso8559-1 and utf8 nls modules as this covers most factory-formatted vfat filesystems. Signed-off-by: Daniel Dickinson <lede@cshore.thecshore.com>
Diffstat (limited to 'package/kernel/linux/modules/fs.mk')
-rw-r--r--package/kernel/linux/modules/fs.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/fs.mk b/package/kernel/linux/modules/fs.mk
index c42260a96f..fbac68bc00 100644
--- a/package/kernel/linux/modules/fs.mk
+++ b/package/kernel/linux/modules/fs.mk
@@ -463,7 +463,7 @@ define KernelPackage/fs-vfat
$(LINUX_DIR)/fs/fat/fat.ko \
$(LINUX_DIR)/fs/fat/vfat.ko
AUTOLOAD:=$(call AutoLoad,30,fat vfat)
- $(call AddDepends/nls)
+ $(call AddDepends/nls,cp437 iso8859-1 utf8)
endef
define KernelPackage/fs-vfat/description