aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/fs.mk
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-01-28 12:01:51 +0000
committerJohn Crispin <blogic@openwrt.org>2015-01-28 12:01:51 +0000
commitdb5b2e531909ad989b2f8dc0e2690bca46e57f49 (patch)
tree386443e39314f09ed3f3035e8d4de9d5f294dd20 /package/kernel/linux/modules/fs.mk
parent16cf695f5e6ce357d7054d16042a161652236d43 (diff)
downloadupstream-db5b2e531909ad989b2f8dc0e2690bca46e57f49.tar.gz
upstream-db5b2e531909ad989b2f8dc0e2690bca46e57f49.tar.bz2
upstream-db5b2e531909ad989b2f8dc0e2690bca46e57f49.zip
kernel: add support for NFSv4
To: openwrt-devel@lists.openwrt.org This work is based on Daniel Colascione's submission to the OpenWrt devel mailing list on January 15th, 2014. I modified his patch so that it applied to the current OpenWrt Barrier Breaker tree. Signed-off-by: W. Michael Petullo <mike@flyn.org> git-svn-id: svn://svn.openwrt.org/openwrt/branches/barrier_breaker@44162 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/fs.mk')
-rw-r--r--package/kernel/linux/modules/fs.mk50
1 files changed, 33 insertions, 17 deletions
diff --git a/package/kernel/linux/modules/fs.mk b/package/kernel/linux/modules/fs.mk
index c1174154a4..9e3470b6d7 100644
--- a/package/kernel/linux/modules/fs.mk
+++ b/package/kernel/linux/modules/fs.mk
@@ -292,12 +292,24 @@ define KernelPackage/fs-nfs/description
Kernel module for NFS support
endef
+define KernelPackage/fs-nfs/config
+ if PACKAGE_kmod-fs-nfs
+ config KERNEL_NFS_V4
+ bool "Support NFSv4 in NFS client"
+ depends on PACKAGE_kmod-fs-sunrpc-auth-rpcgss
+ default n
+ help
+ Select this option to support NFSv4 in the NFS server
+ endif
+endef
+
$(eval $(call KernelPackage,fs-nfs))
define KernelPackage/fs-nfs-common
SUBMENU:=$(FS_MENU)
TITLE:=Common NFS filesystem modules
+ DEPENDS:=+kmod-lib-oid-registry
KCONFIG:= \
CONFIG_LOCKD \
CONFIG_SUNRPC
@@ -310,36 +322,40 @@ endef
$(eval $(call KernelPackage,fs-nfs-common))
-define KernelPackage/fs-nfs-common-v4
+define KernelPackage/fs-sunrpc-auth-rpcgss
SUBMENU:=$(FS_MENU)
- TITLE:=Common NFS V4 filesystem modules
- KCONFIG+=\
- CONFIG_SUNRPC_GSS\
- CONFIG_NFS_V4=y\
- CONFIG_NFSD_V4=y
- DEPENDS:= @BROKEN
- FILES+=$(LINUX_DIR)/net/sunrpc/auth_gss/auth_rpcgss.ko
- AUTOLOAD=$(call AutoLoad,30,auth_rpcgss)
-endef
-
-define KernelPackage/fs-nfs-common-v4/description
- Kernel modules for NFS V4 & NFSD V4 kernel support
+ TITLE:=GSS authentication for SUN RPC
+ DEPENDS:=+kmod-fs-nfs-common
+ KCONFIG:=CONFIG_SUNRPC_GSS
+ FILES:= \
+ $(LINUX_DIR)/net/sunrpc/auth_gss/auth_rpcgss.ko
+ AUTOLOAD:=$(call AutoLoad,30,auth_rpcgss)
endef
-$(eval $(call KernelPackage,fs-nfs-common-v4))
-
+$(eval $(call KernelPackage,fs-sunrpc-auth-rpcgss))
define KernelPackage/fs-nfsd
SUBMENU:=$(FS_MENU)
TITLE:=NFS kernel server support
- DEPENDS:=+kmod-fs-nfs-common +kmod-fs-exportfs
- KCONFIG:= \
+ DEPENDS:=+kmod-fs-nfs-common +kmod-fs-exportfs +kmod-fs-sunrpc-auth-rpcgss
+ KCONFIG= \
CONFIG_NFSD \
CONFIG_NFSD_FAULT_INJECTION=n
FILES:=$(LINUX_DIR)/fs/nfsd/nfsd.ko
AUTOLOAD:=$(call AutoLoad,40,nfsd)
endef
+define KernelPackage/fs-nfsd/config
+ if PACKAGE_kmod-fs-nfsd
+ config KERNEL_NFSD_V4
+ bool "Support NFSv4 in NFS server"
+ depends on PACKAGE_kmod-fs-sunrpc-auth-rpcgss
+ default n
+ help
+ Select this option to support NFSv4 in the NFS server
+ endif
+endef
+
define KernelPackage/fs-nfsd/description
Kernel module for NFS kernel server support
endef