aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/crypto.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2019-08-24 14:02:31 +0200
committerFelix Fietkau <nbd@nbd.name>2019-08-26 18:21:13 +0200
commitc3a78955f34a61d402044f357f54f21c75a19ff9 (patch)
treecef612184685e92313a8263feab83712d40326e7 /package/kernel/linux/modules/crypto.mk
parent0e22e14b6c11a1adf0316f891c9abc6a7b407c5e (diff)
downloadupstream-c3a78955f34a61d402044f357f54f21c75a19ff9.tar.gz
upstream-c3a78955f34a61d402044f357f54f21c75a19ff9.tar.bz2
upstream-c3a78955f34a61d402044f357f54f21c75a19ff9.zip
kernel: move crypto-arc4 into a module
It is no longer required by wireless drivers, so we can save some space here Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/kernel/linux/modules/crypto.mk')
-rw-r--r--package/kernel/linux/modules/crypto.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index 17cb98302d..dc7eb77986 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -46,6 +46,17 @@ endef
$(eval $(call KernelPackage,crypto-aead))
+define KernelPackage/crypto-arc4
+ TITLE:=ARC4 cipher CryptoAPI module
+ KCONFIG:=CONFIG_CRYPTO_ARC4
+ FILES:=$(LINUX_DIR)/crypto/arc4.ko
+ AUTOLOAD:=$(call AutoLoad,09,arc4)
+ $(call AddDepends/crypto)
+endef
+
+$(eval $(call KernelPackage,crypto-arc4))
+
+
define KernelPackage/crypto-authenc
TITLE:=Combined mode wrapper for IPsec
DEPENDS:=+kmod-crypto-manager +kmod-crypto-null