aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/crypto.mk
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2018-11-02 20:40:25 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2018-12-15 14:28:49 +0100
commitf12570659639276d9c253bc42a6bbfc48032ad69 (patch)
tree98841c4a6210cae859870daf13fab771f139e1d8 /package/kernel/linux/modules/crypto.mk
parent6505b084cb8a5609556638247c62245499a172c3 (diff)
downloadupstream-f12570659639276d9c253bc42a6bbfc48032ad69.tar.gz
upstream-f12570659639276d9c253bc42a6bbfc48032ad69.tar.bz2
upstream-f12570659639276d9c253bc42a6bbfc48032ad69.zip
kernel: Add dependencies for kernel 4.19
These dependencies are needed on kernel 4.14 and kernel 4.19. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'package/kernel/linux/modules/crypto.mk')
-rw-r--r--package/kernel/linux/modules/crypto.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index e44a785295..d70eb924c3 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -274,7 +274,7 @@ $(eval $(call KernelPackage,crypto-hmac))
define KernelPackage/crypto-hw-ccp
TITLE:=AMD Cryptographic Coprocessor
- DEPENDS:=+kmod-crypto-authenc +kmod-crypto-hash +kmod-crypto-manager +kmod-random-core +kmod-crypto-sha1 +kmod-crypto-sha256 +LINUX_4_14:kmod-crypto-rsa
+ DEPENDS:=+kmod-crypto-authenc +kmod-crypto-hash +kmod-crypto-manager +kmod-random-core +kmod-crypto-sha1 +kmod-crypto-sha256 +!(LINUX_3_18||LINUX_4_9):kmod-crypto-rsa
KCONFIG:= \
CONFIG_CRYPTO_HW=y \
CONFIG_CRYPTO_DEV_CCP=y \