aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/crypto.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-12-26 11:11:18 +0100
committerFelix Fietkau <nbd@nbd.name>2016-12-26 11:11:49 +0100
commitd109d03198b4ff31d2e4259228a49fa1b3f10390 (patch)
treef29fe95ccb87845f7f7e60e5486f9335e2db8299 /package/kernel/linux/modules/crypto.mk
parent2e41b2c37a0e3efbc43c2d73dface331c5e35b4f (diff)
downloadupstream-d109d03198b4ff31d2e4259228a49fa1b3f10390.tar.gz
upstream-d109d03198b4ff31d2e4259228a49fa1b3f10390.tar.bz2
upstream-d109d03198b4ff31d2e4259228a49fa1b3f10390.zip
kernel: split kmod-lib-zlib into two packages to keep it in sync with kernel dependencies
Fixes build error on default config + selecting kmod-fs-isofs Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/kernel/linux/modules/crypto.mk')
-rw-r--r--package/kernel/linux/modules/crypto.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index 36fb1c31dc..6a076d762e 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -394,7 +394,7 @@ $(eval $(call KernelPackage,crypto-des))
define KernelPackage/crypto-deflate
TITLE:=Deflate compression CryptoAPI module
- DEPENDS:=+kmod-lib-zlib
+ DEPENDS:=+kmod-lib-zlib-inflate +kmod-lib-zlib-deflate
KCONFIG:=CONFIG_CRYPTO_DEFLATE
FILES:=$(LINUX_DIR)/crypto/deflate.ko
AUTOLOAD:=$(call AutoLoad,09,deflate)