aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/block.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2022-09-30 11:42:06 +0200
committerFelix Fietkau <nbd@nbd.name>2022-09-30 12:59:19 +0200
commit2e375e9b3148cfdb9b19494a25eebc2fa7b256a3 (patch)
treee5ea72ab63c875031cd666298a656e1b99c6e64e /package/kernel/linux/modules/block.mk
parent4363faef8a8c975410f001858b010170942aacfc (diff)
downloadupstream-2e375e9b3148cfdb9b19494a25eebc2fa7b256a3.tar.gz
upstream-2e375e9b3148cfdb9b19494a25eebc2fa7b256a3.tar.bz2
upstream-2e375e9b3148cfdb9b19494a25eebc2fa7b256a3.zip
kernel: remove hack patch, move kirkwood specific kmods to target modules.mk
Tweaking the KCONFIG line of kmod-ata-marvell-sata makes the hack patch unnecessary Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/kernel/linux/modules/block.mk')
-rw-r--r--package/kernel/linux/modules/block.mk15
1 files changed, 0 insertions, 15 deletions
diff --git a/package/kernel/linux/modules/block.mk b/package/kernel/linux/modules/block.mk
index 8affa72296..f6c9df0698 100644
--- a/package/kernel/linux/modules/block.mk
+++ b/package/kernel/linux/modules/block.mk
@@ -90,21 +90,6 @@ endef
$(eval $(call KernelPackage,ata-artop))
-define KernelPackage/ata-marvell-sata
- TITLE:=Marvell Serial ATA support
- KCONFIG:=CONFIG_SATA_MV
- FILES:=$(LINUX_DIR)/drivers/ata/sata_mv.ko
- AUTOLOAD:=$(call AutoLoad,41,sata_mv,1)
- $(call AddDepends/ata)
-endef
-
-define KernelPackage/ata-marvell-sata/description
- SATA support for marvell chipsets
-endef
-
-$(eval $(call KernelPackage,ata-marvell-sata))
-
-
define KernelPackage/ata-nvidia-sata
TITLE:=Nvidia Serial ATA support
KCONFIG:=CONFIG_SATA_NV