aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/block.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-05-21 19:09:59 +0200
committerFelix Fietkau <nbd@nbd.name>2016-05-21 19:57:06 +0200
commitf849c2c83247340d623fdb549e2b75f4c1feea62 (patch)
tree2d55138ecd6dd651e2343c1642e80c29522255b4 /package/kernel/linux/modules/block.mk
parenta5a3b59bf54c72c1eea7745d7a83dfc298d4ae1e (diff)
downloadupstream-f849c2c83247340d623fdb549e2b75f4c1feea62.tar.gz
upstream-f849c2c83247340d623fdb549e2b75f4c1feea62.tar.bz2
upstream-f849c2c83247340d623fdb549e2b75f4c1feea62.zip
mvebu: enable core drivers in the kernel config instead of packaging them
Simplify profile package selection Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/kernel/linux/modules/block.mk')
-rw-r--r--package/kernel/linux/modules/block.mk18
1 files changed, 1 insertions, 17 deletions
diff --git a/package/kernel/linux/modules/block.mk b/package/kernel/linux/modules/block.mk
index 0c8d9b1fe9..d7f5ca4762 100644
--- a/package/kernel/linux/modules/block.mk
+++ b/package/kernel/linux/modules/block.mk
@@ -65,7 +65,7 @@ define KernelPackage/ata-ahci-platform
$(LINUX_DIR)/drivers/ata/ahci_platform.ko \
$(LINUX_DIR)/drivers/ata/libahci_platform.ko
AUTOLOAD:=$(call AutoLoad,40,libahci libahci_platform ahci_platform,1)
- $(call AddDepends/ata,@TARGET_ipq806x||TARGET_mvebu||TARGET_sunxi)
+ $(call AddDepends/ata,@TARGET_ipq806x||TARGET_sunxi)
endef
define KernelPackage/ata-ahci-platform/description
@@ -124,22 +124,6 @@ endef
$(eval $(call KernelPackage,ata-marvell-sata))
-define KernelPackage/ata-mvebu-ahci
- TITLE:=Marvell EBU AHCI support
- DEPENDS:=@TARGET_mvebu +kmod-ata-ahci-platform
- KCONFIG:=CONFIG_AHCI_MVEBU
- FILES:=$(LINUX_DIR)/drivers/ata/ahci_mvebu.ko
- AUTOLOAD:=$(call AutoLoad,41,ahci_mvebu,1)
- $(call AddDepends/ata)
-endef
-
-define KernelPackage/ata-mvebu-ahci/description
- AHCI support for Marvell EBU SoCs
-endef
-
-$(eval $(call KernelPackage,ata-mvebu-ahci))
-
-
define KernelPackage/ata-nvidia-sata
TITLE:=Nvidia Serial ATA support
KCONFIG:=CONFIG_SATA_NV