aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/block.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-07-11 20:56:22 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-07-11 20:56:22 +0000
commitc38b7b391357b8b18fb12ee33d5230b287f45011 (patch)
tree792b1a9d71321e35e47cf0ca32acea9b6a19dbf0 /package/kernel/linux/modules/block.mk
parent19e3ec0570a73b7a8f9633c956bb665d2d761413 (diff)
downloadupstream-c38b7b391357b8b18fb12ee33d5230b287f45011.tar.gz
upstream-c38b7b391357b8b18fb12ee33d5230b287f45011.tar.bz2
upstream-c38b7b391357b8b18fb12ee33d5230b287f45011.zip
kernel: make libsas depend on x86
It is only used by one driver that already depends on x86. Disabling it prevents a few kilobytes of bloat from leaking into all targets via CONFIG_BLK_DEV_BSG Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 37254
Diffstat (limited to 'package/kernel/linux/modules/block.mk')
-rw-r--r--package/kernel/linux/modules/block.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/block.mk b/package/kernel/linux/modules/block.mk
index 1aa47def2d..d92010b8c9 100644
--- a/package/kernel/linux/modules/block.mk
+++ b/package/kernel/linux/modules/block.mk
@@ -491,6 +491,7 @@ $(eval $(call KernelPackage,ide-it821x))
define KernelPackage/libsas
SUBMENU:=$(BLOCK_MENU)
+ DEPENDS:=@TARGET_x86
TITLE:=SAS Domain Transport Attributes
KCONFIG:=CONFIG_SCSI_SAS_LIBSAS \
CONFIG_SCSI_SAS_ATTRS \