aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/block.mk
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2015-04-12 15:02:43 +0000
committerImre Kaloz <kaloz@openwrt.org>2015-04-12 15:02:43 +0000
commit8de815c4e7f8221df43d43a423fc734c0e6cdbcc (patch)
treec1cbbd0643cded464daad220208537f27384e80c /package/kernel/linux/modules/block.mk
parent6cfe1539da954a69ed41c6e8d424a34406285ac3 (diff)
downloadupstream-8de815c4e7f8221df43d43a423fc734c0e6cdbcc.tar.gz
upstream-8de815c4e7f8221df43d43a423fc734c0e6cdbcc.tar.bz2
upstream-8de815c4e7f8221df43d43a423fc734c0e6cdbcc.zip
modules: package the mvebu ahci driver
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> SVN-Revision: 45394
Diffstat (limited to 'package/kernel/linux/modules/block.mk')
-rw-r--r--package/kernel/linux/modules/block.mk18
1 files changed, 17 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/block.mk b/package/kernel/linux/modules/block.mk
index 46cb99c834..2d79e51021 100644
--- a/package/kernel/linux/modules/block.mk
+++ b/package/kernel/linux/modules/block.mk
@@ -63,7 +63,7 @@ define KernelPackage/ata-ahci-platform
$(LINUX_DIR)/drivers/ata/ahci_platform.ko \
$(LINUX_DIR)/drivers/ata/libahci_platform.ko
AUTOLOAD:=$(call AutoLoad,40,libahci_platform ahci_platform,1)
- $(call AddDepends/ata,@TARGET_ipq806x +kmod-ata-ahci)
+ $(call AddDepends/ata,@TARGET_ipq806x||TARGET_mvebu +kmod-ata-ahci)
endef
define KernelPackage/ata-ahci-platform/description
@@ -122,6 +122,22 @@ endef
$(eval $(call KernelPackage,ata-marvell-sata))
+define KernelPackage/ata-mvebu-ahci
+ TITLE:=Marvell EBU AHCI support
+ DEPENDS:=@TARGET_mvebu +kmod-ata-ahci-platform
+ KCONFIG:=CONFIG_AHCI_MVEBU
+ FILES:=$(LINUX_DIR)/drivers/ata/ahci_mvebu.ko
+ AUTOLOAD:=$(call AutoLoad,41,ahci_mvebu,1)
+ $(call AddDepends/ata)
+endef
+
+define KernelPackage/ata-mvebu-ahci/description
+ AHCI support for Marvell EBU SoCs
+endef
+
+$(eval $(call KernelPackage,ata-mvebu-ahci))
+
+
define KernelPackage/ata-nvidia-sata
TITLE:=Nvidia Serial ATA support
KCONFIG:=CONFIG_SATA_NV