aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/block.mk
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-02-24 12:00:16 +0000
committerJohn Crispin <john@openwrt.org>2015-02-24 12:00:16 +0000
commit3f22244009818d37da721472b4ee6ff80d0ad3af (patch)
tree51bddf3ed2aee554daf18bc0dab8f39d4536dd16 /package/kernel/linux/modules/block.mk
parent458c37fb14498f43604e75fc9d2d3c8e7c72626d (diff)
downloadupstream-3f22244009818d37da721472b4ee6ff80d0ad3af.tar.gz
upstream-3f22244009818d37da721472b4ee6ff80d0ad3af.tar.bz2
upstream-3f22244009818d37da721472b4ee6ff80d0ad3af.zip
modules: add ahci-platform
Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 44524
Diffstat (limited to 'package/kernel/linux/modules/block.mk')
-rw-r--r--package/kernel/linux/modules/block.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/block.mk b/package/kernel/linux/modules/block.mk
index 20588ac276..159155e049 100644
--- a/package/kernel/linux/modules/block.mk
+++ b/package/kernel/linux/modules/block.mk
@@ -56,6 +56,23 @@ endef
$(eval $(call KernelPackage,ata-ahci))
+define KernelPackage/ata-ahci-platform
+ TITLE:=AHCI Serial ATA Platform support
+ KCONFIG:=CONFIG_SATA_AHCI_PLATFORM
+ FILES:= \
+ $(LINUX_DIR)/drivers/ata/ahci_platform.ko \
+ $(LINUX_DIR)/drivers/ata/libahci_platform.ko
+ AUTOLOAD:=$(call AutoLoad,40,libahci_platform ahci_platform,1)
+ $(call AddDepends/ata,+kmod-ata-ahci)
+endef
+
+define KernelPackage/ata-ahci-platform/description
+ Platform support for AHCI Serial ATA controllers
+endef
+
+$(eval $(call KernelPackage,ata-ahci-platform))
+
+
define KernelPackage/ata-artop
TITLE:=ARTOP 6210/6260 PATA support
KCONFIG:=CONFIG_PATA_ARTOP