aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/block.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-01-22 11:40:17 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-27 11:18:27 +0100
commit28af0f2fbd4fb66ecebdbbeca385054a2b105d3d (patch)
tree79098f361ad94ec69a33b6b842ac8bb4e38745be /package/kernel/linux/modules/block.mk
parent0519bafbdaef7b2b6d3b553fa487e625f87fd176 (diff)
downloadupstream-28af0f2fbd4fb66ecebdbbeca385054a2b105d3d.tar.gz
upstream-28af0f2fbd4fb66ecebdbbeca385054a2b105d3d.tar.bz2
upstream-28af0f2fbd4fb66ecebdbbeca385054a2b105d3d.zip
kernel: make kmod package dependencies forward compatible
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/kernel/linux/modules/block.mk')
-rw-r--r--package/kernel/linux/modules/block.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/block.mk b/package/kernel/linux/modules/block.mk
index 508b3abd5d..62f08218c6 100644
--- a/package/kernel/linux/modules/block.mk
+++ b/package/kernel/linux/modules/block.mk
@@ -326,7 +326,7 @@ $(eval $(call KernelPackage,md-raid10))
define KernelPackage/md-raid456
-$(call KernelPackage/md/Depends,+kmod-lib-raid6 +kmod-lib-xor +LINUX_4_4:kmod-lib-crc32c)
+$(call KernelPackage/md/Depends,+kmod-lib-raid6 +kmod-lib-xor +!LINUX_3_18:kmod-lib-crc32c)
TITLE:=RAID Level 456 Driver
KCONFIG:= \
CONFIG_ASYNC_CORE \