aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/block.mk
diff options
context:
space:
mode:
authorChris Koying Browet <cbro@semperpax.com>2018-12-27 13:07:40 +0100
committerChristian Lamparter <chunkeey@gmail.com>2019-06-20 20:02:29 +0200
commit0e961a1f9f7ea3f796d44dbc43b580bf02f15d96 (patch)
tree5a45d4321478cf37243d526c4b933f6a7e7fe36e /package/kernel/linux/modules/block.mk
parent99bf9a1ac2b754e708ec845059689b293d1abab0 (diff)
downloadupstream-0e961a1f9f7ea3f796d44dbc43b580bf02f15d96.tar.gz
upstream-0e961a1f9f7ea3f796d44dbc43b580bf02f15d96.tar.bz2
upstream-0e961a1f9f7ea3f796d44dbc43b580bf02f15d96.zip
kernel: dm: add dm-raid for LVM raid
This adds the dm-raid kmod, which is needed for LVM builtin raid configurations, aka "MD-over-LVM" Signed-off-by: Chris Koying Browet <cbro@semperpax.com>
Diffstat (limited to 'package/kernel/linux/modules/block.mk')
-rw-r--r--package/kernel/linux/modules/block.mk24
1 files changed, 23 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/block.mk b/package/kernel/linux/modules/block.mk
index 3bc607c12e..c486a433c2 100644
--- a/package/kernel/linux/modules/block.mk
+++ b/package/kernel/linux/modules/block.mk
@@ -239,7 +239,12 @@ define KernelPackage/dm
CONFIG_BLK_DEV_DM \
CONFIG_DM_CRYPT \
CONFIG_DM_MIRROR
- FILES:=$(LINUX_DIR)/drivers/md/dm-*.ko
+ FILES:= \
+ $(LINUX_DIR)/drivers/md/dm-mod.ko \
+ $(LINUX_DIR)/drivers/md/dm-crypt.ko \
+ $(LINUX_DIR)/drivers/md/dm-log.ko \
+ $(LINUX_DIR)/drivers/md/dm-mirror.ko \
+ $(LINUX_DIR)/drivers/md/dm-region-hash.ko
AUTOLOAD:=$(call AutoLoad,30,dm-mod dm-log dm-region-hash dm-mirror dm-crypt)
endef
@@ -249,6 +254,23 @@ endef
$(eval $(call KernelPackage,dm))
+define KernelPackage/dm-raid
+ SUBMENU:=$(BLOCK_MENU)
+ TITLE:=LVM2 raid support
+ DEPENDS:=+kmod-dm +kmod-md-mod \
+ +kmod-md-raid0 +kmod-md-raid1 +kmod-md-raid10 +kmod-md-raid456
+ KCONFIG:= \
+ CONFIG_DM_RAID
+ FILES:=$(LINUX_DIR)/drivers/md/dm-raid.ko
+ AUTOLOAD:=$(call AutoLoad,31,dm-raid)
+endef
+
+define KernelPackage/dm-raid/description
+ Kernel module necessary for LVM2 raid support
+endef
+
+$(eval $(call KernelPackage,dm-raid))
+
define KernelPackage/md-mod
SUBMENU:=$(BLOCK_MENU)