aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/leds-apu2/Makefile
diff options
context:
space:
mode:
authorFlorian Eckert <fe@dev.tdt.de>2018-07-30 08:24:03 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2020-06-26 20:54:53 +0200
commit2b550a6be198ff78ac672d654d867ff1a0a13760 (patch)
treedd8536c51e8fd0044cfd869a102fa063388888a2 /package/kernel/leds-apu2/Makefile
parent635f111148c3f7ccb0ecc92863a3b1a142f6ebeb (diff)
downloadupstream-2b550a6be198ff78ac672d654d867ff1a0a13760.tar.gz
upstream-2b550a6be198ff78ac672d654d867ff1a0a13760.tar.bz2
upstream-2b550a6be198ff78ac672d654d867ff1a0a13760.zip
kernel/leds-apu2: remove deprecated leds-apu2 driver
Remove leds-apu2 out of tree driver. There is a new upstream device gpio and leds driver stack available for the APUv2 and APUv3 boards from pc egnines. This new driver stack was add in kernel version 4.15. Signed-off-by: Florian Eckert <fe@dev.tdt.de>
Diffstat (limited to 'package/kernel/leds-apu2/Makefile')
-rw-r--r--package/kernel/leds-apu2/Makefile51
1 files changed, 0 insertions, 51 deletions
diff --git a/package/kernel/leds-apu2/Makefile b/package/kernel/leds-apu2/Makefile
deleted file mode 100644
index 1d01548ba2..0000000000
--- a/package/kernel/leds-apu2/Makefile
+++ /dev/null
@@ -1,51 +0,0 @@
-#
-# Copyright (C) 2017 Chris Blake <chrisrblake93@gmail.com>
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/kernel.mk
-
-PKG_NAME:=leds-apu2
-PKG_RELEASE:=1
-
-PKG_MAINTAINER:=Chris Blake <chrisrblake93@gmail.com>
-PKG_LICENSE:=GPL-2.0
-
-include $(INCLUDE_DIR)/package.mk
-
-define KernelPackage/leds-apu2
- SUBMENU:=LED modules
- TITLE:= PC Engines APU2/APU3 LED support
- DEPENDS:= @GPIO_SUPPORT @TARGET_x86
- FILES:=$(PKG_BUILD_DIR)/leds-apu2.ko
- AUTOLOAD:=$(call AutoLoad,41,leds-apu2,1)
- KCONFIG:=
-endef
-
-define KernelPackage/leds-apu2/description
- Driver for the PC Engines APU2/APU3 LEDs & Reset Button.
-endef
-
-EXTRA_KCONFIG:= \
- CONFIG_LEDS_APU2=m
-
-EXTRA_CFLAGS:= \
- $(patsubst CONFIG_%, -DCONFIG_%=1, $(patsubst %=m,%,$(filter %=m,$(EXTRA_KCONFIG)))) \
- $(patsubst CONFIG_%, -DCONFIG_%=1, $(patsubst %=y,%,$(filter %=y,$(EXTRA_KCONFIG)))) \
-
-MAKE_OPTS:= \
- $(KERNEL_MAKE_FLAGS) \
- M="$(PKG_BUILD_DIR)" \
- EXTRA_CFLAGS="$(EXTRA_CFLAGS)" \
- $(EXTRA_KCONFIG)
-
-define Build/Compile
- $(MAKE) -C "$(LINUX_DIR)" \
- $(MAKE_OPTS) \
- modules
-endef
-
-$(eval $(call KernelPackage,leds-apu2))