aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/lantiq
diff options
context:
space:
mode:
authorAndre Heider <a.heider@gmail.com>2021-12-18 11:59:47 +0100
committerDaniel Golle <daniel@makrotopia.org>2023-01-16 23:41:41 +0000
commit2a0aa9eefadb3bad415eae84e023af70c06b020c (patch)
tree5ba2d98116204e4401a4dad3157c62cba1f3b607 /package/kernel/lantiq
parent474bbe23b7ec72ba84b9b7c91e17a69f58bd88b2 (diff)
downloadupstream-2a0aa9eefadb3bad415eae84e023af70c06b020c.tar.gz
upstream-2a0aa9eefadb3bad415eae84e023af70c06b020c.tar.bz2
upstream-2a0aa9eefadb3bad415eae84e023af70c06b020c.zip
ltq-ifxos: enable for ipq40xx
This is required for the MEI CPE driver. Signed-off-by: Andre Heider <a.heider@gmail.com>
Diffstat (limited to 'package/kernel/lantiq')
-rw-r--r--package/kernel/lantiq/ltq-ifxos/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/package/kernel/lantiq/ltq-ifxos/Makefile b/package/kernel/lantiq/ltq-ifxos/Makefile
index bc586faaf1..e8f41665dd 100644
--- a/package/kernel/lantiq/ltq-ifxos/Makefile
+++ b/package/kernel/lantiq/ltq-ifxos/Makefile
@@ -32,7 +32,7 @@ define KernelPackage/ltq-ifxos
SUBMENU:=Libraries
TITLE:=Lantiq OS abstraction library
URL:=http://www.lantiq.com/
- DEPENDS:=@TARGET_lantiq
+ DEPENDS:=@(TARGET_lantiq||TARGET_ipq40xx)
FILES:=$(PKG_BUILD_DIR)/src/drv_ifxos.ko
AUTOLOAD:=$(call AutoLoad,10,drv_ifxos)
endef
@@ -44,13 +44,11 @@ CONFIGURE_ARGS += \
--enable-kernelincl="$(LINUX_DIR)/include" \
--with-kernel-module
-ifdef CONFIG_TARGET_lantiq
- define Build/InstallDev
+define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/{lib,include/ifxos}
$(CP) $(PKG_BUILD_DIR)/src/include/* $(1)/usr/include/ifxos
mkdir -p $(1)/usr/lib
$(CP) $(PKG_BUILD_DIR)/src/.libs/libifxos.a $(1)/usr/lib/libifxos.a
- endef
-endif
+endef
$(eval $(call KernelPackage,ltq-ifxos))