aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/lantiq
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2022-01-16 22:31:22 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2022-01-21 23:09:24 +0100
commit71bdff9139a469380f1b0a42425fa091dbb16f88 (patch)
tree97898ca05bb34b6fe64ae6643d18710fc138ab44 /package/kernel/lantiq
parent408b6558e4c4e547d3dc68d5c1e26d0a97a287a9 (diff)
downloadupstream-71bdff9139a469380f1b0a42425fa091dbb16f88.tar.gz
upstream-71bdff9139a469380f1b0a42425fa091dbb16f88.tar.bz2
upstream-71bdff9139a469380f1b0a42425fa091dbb16f88.zip
ltq-vdsl-mei: Remove static linking
This removes -static compile option. The -static option tells GCC to link this statically with the libc, which we do not want in OpenWrt. We want to link everything dynamically to the libc. This fixes a compile problem with glibc. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'package/kernel/lantiq')
-rw-r--r--package/kernel/lantiq/ltq-vdsl-mei/patches/030-no-static-linking.patch47
1 files changed, 47 insertions, 0 deletions
diff --git a/package/kernel/lantiq/ltq-vdsl-mei/patches/030-no-static-linking.patch b/package/kernel/lantiq/ltq-vdsl-mei/patches/030-no-static-linking.patch
new file mode 100644
index 0000000000..8d4fca1eb1
--- /dev/null
+++ b/package/kernel/lantiq/ltq-vdsl-mei/patches/030-no-static-linking.patch
@@ -0,0 +1,47 @@
+This removes -static compile option. The -static option tells GCC to
+link this statically with the libc, which we do not want in OpenWrt. We
+want to link everything dynamically to the libc. This fixes a compile
+problem with glibc.
+
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -198,10 +198,10 @@ AM_CFLAGS = -Wall -Wimplicit -Wunused -W
+
+ if IFXOS_ENABLE
+ AM_LDFLAGS= \
+- -Bstatic -dn -static @IFXOS_LIBRARY_PATH@
++ -Bstatic -dn @IFXOS_LIBRARY_PATH@
+ else
+ AM_LDFLAGS= \
+- -Bstatic -dn -static
++ -Bstatic -dn
+ endif
+
+ #
+@@ -304,7 +304,7 @@ mei_cpe_appl_ldflags= $(ADD_APPL_LDFLAGS
+ else
+ if TARGET_ADM5120_MIPSEL
+ mei_cpe_appl_cflags = -O1 -g
+-mei_cpe_appl_ldflags = -static
++mei_cpe_appl_ldflags =
+ else
+ mei_cpe_appl_cflags = -DPPC
+ endif
+@@ -318,7 +318,7 @@ mei_cpe_drv_test_CPPFLAGS = -I@srcdir@\
+ mei_cpe_drv_test_CFLAGS = $(mei_cpe_app_common_cflags) \
+ $(mei_cpe_appl_cflags) $(MEI_DRV_TARGET_OPTIONS)
+
+-mei_cpe_drv_test_LDFLAGS = $(mei_cpe_appl_ldflags) -Bstatic -dn -static @IFXOS_LIBRARY_PATH@
++mei_cpe_drv_test_LDFLAGS = $(mei_cpe_appl_ldflags) -Bstatic -dn @IFXOS_LIBRARY_PATH@
+
+ mei_cpe_drv_test_LDADD = -lifxos
+ endif
+@@ -333,7 +333,7 @@ mei_cpe_drv_dbg_strm_dmp_CPPFLAGS = -I@s
+ -I@KERNEL_INCL_PATH@ $(IFXOS_INCLUDE_PATH)
+ mei_cpe_drv_dbg_strm_dmp_CFLAGS = $(mei_cpe_app_common_cflags) \
+ $(mei_cpe_appl_cflags) $(MEI_DRV_TARGET_OPTIONS)
+-mei_cpe_drv_dbg_strm_dmp_LDFLAGS = $(mei_cpe_appl_ldflags) -Bstatic -dn -static @IFXOS_LIBRARY_PATH@
++mei_cpe_drv_dbg_strm_dmp_LDFLAGS = $(mei_cpe_appl_ldflags) -Bstatic -dn @IFXOS_LIBRARY_PATH@
+ mei_cpe_drv_dbg_strm_dmp_LDADD = -lifxos
+
+ # linux 2.6 kernel object - dummy to force dependencies