aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/lantiq/ltq-vdsl/Makefile
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2018-03-03 00:25:06 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2018-03-03 12:58:55 +0100
commitb5c5f7d203aae4b9531e423f593f80f7c9445ea3 (patch)
tree1b160f5964b2f3032e08bae61ee871b2422ff836 /package/kernel/lantiq/ltq-vdsl/Makefile
parent13639e76dd2431d3688c4dda352b4f1fe24cb7ff (diff)
downloadupstream-b5c5f7d203aae4b9531e423f593f80f7c9445ea3.tar.gz
upstream-b5c5f7d203aae4b9531e423f593f80f7c9445ea3.tar.bz2
upstream-b5c5f7d203aae4b9531e423f593f80f7c9445ea3.zip
lantiq: ltq-vdsl: Do not leak user space CFLAGS into kernel space
Do not leak the user space CFLAGS into the kernel space any more, this allows us to activate the MIPS16 build. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'package/kernel/lantiq/ltq-vdsl/Makefile')
-rw-r--r--package/kernel/lantiq/ltq-vdsl/Makefile7
1 files changed, 2 insertions, 5 deletions
diff --git a/package/kernel/lantiq/ltq-vdsl/Makefile b/package/kernel/lantiq/ltq-vdsl/Makefile
index 3b085ed8a7..d518bd647d 100644
--- a/package/kernel/lantiq/ltq-vdsl/Makefile
+++ b/package/kernel/lantiq/ltq-vdsl/Makefile
@@ -9,7 +9,7 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=ltq-vdsl-vr9
PKG_VERSION:=4.17.18.6
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_BASE_NAME:=drv_dsl_cpe_api
PKG_SOURCE:=$(PKG_BASE_NAME)_vrx-$(PKG_VERSION).tar.gz
@@ -19,8 +19,7 @@ PKG_HASH:=b4966a60653acc49254b168c6cc9c49eb36c54548e763617788aa4f252a29f21
PKG_LICENSE:=GPL-2.0 BSD-2-Clause
PKG_LICENSE_FILES:=LICENSE
-
-PKG_USE_MIPS16:=0
+PKG_FIXUP:=autoreconf
PKG_MAINTAINER:=John Crispin <john@phrozen.org>
@@ -42,8 +41,6 @@ define Package/ltq-vdsl-vr9/description
- VRX200 Family
endef
-EXTRA_CFLAGS = -fno-pic -mno-abicalls -mlong-calls -G 0
-
MAKE_FLAGS += \
SHELL="$(BASH)"