aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/lantiq/ltq-vdsl-fw/src/Makefile
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2018-06-15 11:56:05 +0200
committerDaniel Golle <daniel@makrotopia.org>2018-06-15 12:45:37 +0200
commit8e2f8b0c835091e0c0cabc70f219cff317f4823d (patch)
treecbe2a721fe01dcf09803456f8a26c64e4c14ffed /package/kernel/lantiq/ltq-vdsl-fw/src/Makefile
parentf47d7df6a89ae9457fc99dcb44c35969aa40b7a8 (diff)
downloadupstream-8e2f8b0c835091e0c0cabc70f219cff317f4823d.tar.gz
upstream-8e2f8b0c835091e0c0cabc70f219cff317f4823d.tar.bz2
upstream-8e2f8b0c835091e0c0cabc70f219cff317f4823d.zip
Revert "lantiq: get rid of ltq-vdsl-fw"
This reverts commit 0938233fcdef67d969f9429a10761cc640c6d56d. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'package/kernel/lantiq/ltq-vdsl-fw/src/Makefile')
-rw-r--r--package/kernel/lantiq/ltq-vdsl-fw/src/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/package/kernel/lantiq/ltq-vdsl-fw/src/Makefile b/package/kernel/lantiq/ltq-vdsl-fw/src/Makefile
new file mode 100644
index 0000000000..2d50aaf023
--- /dev/null
+++ b/package/kernel/lantiq/ltq-vdsl-fw/src/Makefile
@@ -0,0 +1,13 @@
+PROG=w921v_fw_cutter
+OBJS=w921v_fw_cutter.c LzmaDecode.c LzmaWrapper.c
+
+all: $(PROG)
+
+$(PROG): $(OBJS)
+ $(CC) $(CFLAGS) $(LDFLAGS) $^ -o $@
+
+clean:
+ rm *.o $(PROG)
+
+%.o: %.c
+ $(CC) $(CFLAGS) -c $^ -o $@