aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/lantiq/ltq-vdsl-fw/Makefile
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2018-06-15 11:56:05 +0200
committerDaniel Golle <daniel@makrotopia.org>2018-06-15 12:45:37 +0200
commit8e2f8b0c835091e0c0cabc70f219cff317f4823d (patch)
treecbe2a721fe01dcf09803456f8a26c64e4c14ffed /package/kernel/lantiq/ltq-vdsl-fw/Makefile
parentf47d7df6a89ae9457fc99dcb44c35969aa40b7a8 (diff)
downloadupstream-8e2f8b0c835091e0c0cabc70f219cff317f4823d.tar.gz
upstream-8e2f8b0c835091e0c0cabc70f219cff317f4823d.tar.bz2
upstream-8e2f8b0c835091e0c0cabc70f219cff317f4823d.zip
Revert "lantiq: get rid of ltq-vdsl-fw"
This reverts commit 0938233fcdef67d969f9429a10761cc640c6d56d. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'package/kernel/lantiq/ltq-vdsl-fw/Makefile')
-rw-r--r--package/kernel/lantiq/ltq-vdsl-fw/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/package/kernel/lantiq/ltq-vdsl-fw/Makefile b/package/kernel/lantiq/ltq-vdsl-fw/Makefile
new file mode 100644
index 0000000000..6404067707
--- /dev/null
+++ b/package/kernel/lantiq/ltq-vdsl-fw/Makefile
@@ -0,0 +1,40 @@
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=ltq-vdsl-fw
+PKG_VERSION:=1
+PKG_RELEASE:=1
+
+PKG_MAINTAINER:=John Crispin <blogic@openwrt.org>
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/ltq-vdsl-vr9-fw-installer
+ TITLE:=Firmware installer
+ SECTION:=net
+ CATEGORY:=Network
+ DEPENDS:=@TARGET_lantiq_xrx200 +kmod-ltq-vdsl-vr9
+endef
+
+define Build/Prepare
+ $(INSTALL_DIR) $(PKG_BUILD_DIR)
+ $(CP) ./src/* $(PKG_BUILD_DIR)
+endef
+
+define Build/Compile
+ $(TARGET_CONFIGURE_OPTS) \
+ CFLAGS="$(TARGET_CFLAGS)" \
+ LDFLAGS="$(TARGET_LDFLAGS)" \
+ $(MAKE) -C $(PKG_BUILD_DIR)
+endef
+
+define Package/ltq-vdsl-vr9-fw-installer/install
+ $(INSTALL_DIR) $(1)/sbin
+ $(CP) $(PKG_BUILD_DIR)/w921v_fw_cutter $(PKG_BUILD_DIR)/vdsl_fw_install.sh $(1)/sbin/
+endef
+
+$(eval $(call BuildPackage,ltq-vdsl-vr9-fw-installer))