aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/lantiq/ltq-vdsl-fw/Makefile
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2018-06-15 12:21:03 +0200
committerDaniel Golle <daniel@makrotopia.org>2018-06-15 12:45:37 +0200
commit0653e3127054993e908878f70fbbe1a1b784dd61 (patch)
tree3246366ffa928e174b947c66148d604772dfad1c /package/kernel/lantiq/ltq-vdsl-fw/Makefile
parent8e2f8b0c835091e0c0cabc70f219cff317f4823d (diff)
downloadupstream-0653e3127054993e908878f70fbbe1a1b784dd61.tar.gz
upstream-0653e3127054993e908878f70fbbe1a1b784dd61.tar.bz2
upstream-0653e3127054993e908878f70fbbe1a1b784dd61.zip
lantiq-vdsl-fw: update to provide recent vectoring firmware
Recent Speedport firmware downloads only work over HTTPS, so the user either needs to provide the already downloaded file or install ustream-ssl-* as well as ca-certificates or ca-bundle. So to get VDSL2 with vectoring on xRX200, simply run vdsl_fw_install.sh on the target and either provide the downloaded file as instructed or make sure the device is connected to the Internet and can download that HTTPS url itself. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'package/kernel/lantiq/ltq-vdsl-fw/Makefile')
-rw-r--r--package/kernel/lantiq/ltq-vdsl-fw/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/package/kernel/lantiq/ltq-vdsl-fw/Makefile b/package/kernel/lantiq/ltq-vdsl-fw/Makefile
index 6404067707..f021aa3dcf 100644
--- a/package/kernel/lantiq/ltq-vdsl-fw/Makefile
+++ b/package/kernel/lantiq/ltq-vdsl-fw/Makefile
@@ -9,12 +9,12 @@ PKG_NAME:=ltq-vdsl-fw
PKG_VERSION:=1
PKG_RELEASE:=1
-PKG_MAINTAINER:=John Crispin <blogic@openwrt.org>
+PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
include $(INCLUDE_DIR)/package.mk
-define Package/ltq-vdsl-vr9-fw-installer
- TITLE:=Firmware installer
+define Package/ltq-vdsl-vr9-vectoring-fw-installer
+ TITLE:=VDSL2 Vectoring Firmware installer
SECTION:=net
CATEGORY:=Network
DEPENDS:=@TARGET_lantiq_xrx200 +kmod-ltq-vdsl-vr9
@@ -37,4 +37,4 @@ define Package/ltq-vdsl-vr9-fw-installer/install
$(CP) $(PKG_BUILD_DIR)/w921v_fw_cutter $(PKG_BUILD_DIR)/vdsl_fw_install.sh $(1)/sbin/
endef
-$(eval $(call BuildPackage,ltq-vdsl-vr9-fw-installer))
+$(eval $(call BuildPackage,ltq-vdsl-vr9-vectoring-fw-installer))