aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/lantiq/ltq-hcd
diff options
context:
space:
mode:
authorJohn Crispin <john@phrozen.org>2016-06-13 19:04:56 +0200
committerJohn Crispin <john@phrozen.org>2016-06-13 22:51:43 +0200
commitabc346db0e191ebeeb122ce26d1831469fadee1c (patch)
treecd4af73b7eb7eb22aed5bf5d39ff302e7203378f /package/kernel/lantiq/ltq-hcd
parent239ad94165adc3ffb5290dd871d2ff0ddff4bdcf (diff)
downloadupstream-abc346db0e191ebeeb122ce26d1831469fadee1c.tar.gz
upstream-abc346db0e191ebeeb122ce26d1831469fadee1c.tar.bz2
upstream-abc346db0e191ebeeb122ce26d1831469fadee1c.zip
package/lantiq: make lantiq kernel modules work with xway_legacy
Signed-off-by: John Crispin <john@phrozen.org>
Diffstat (limited to 'package/kernel/lantiq/ltq-hcd')
-rw-r--r--package/kernel/lantiq/ltq-hcd/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/package/kernel/lantiq/ltq-hcd/Makefile b/package/kernel/lantiq/ltq-hcd/Makefile
index f774e6f897..5f3767206d 100644
--- a/package/kernel/lantiq/ltq-hcd/Makefile
+++ b/package/kernel/lantiq/ltq-hcd/Makefile
@@ -23,14 +23,14 @@ define KernelPackage/ltq-hcd-template
TITLE:=USB driver for $(1)
URL:=http://www.lantiq.com/
VARIANT:=$(1)
- DEPENDS:=@TARGET_lantiq_$(2) +kmod-usb-core
+ DEPENDS:=@$(2) +kmod-usb-core
FILES:=$(PKG_BUILD_DIR)/ltq_hcd_$(1).ko
AUTOLOAD:=$(call AutoProbe,ltq_hcd_$(1),1)
endef
-KernelPackage/ltq-hcd-ase=$(call KernelPackage/ltq-hcd-template,ase,ase)
-KernelPackage/ltq-hcd-danube=$(call KernelPackage/ltq-hcd-template,danube,xway)
-KernelPackage/ltq-hcd-ar9=$(call KernelPackage/ltq-hcd-template,ar9,xway)
+KernelPackage/ltq-hcd-ase=$(call KernelPackage/ltq-hcd-template,ase,TARGET_lantiq_ase)
+KernelPackage/ltq-hcd-danube=$(call KernelPackage/ltq-hcd-template,(TARGET_lantiq_xway||TARGET_lantiq_xway_legacy))
+KernelPackage/ltq-hcd-ar9=$(call KernelPackage/ltq-hcd-template,ar9,TARGET_lantiq_xway)
define Build/Prepare
$(INSTALL_DIR) $(PKG_BUILD_DIR)