aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/lantiq/ltq-adsl/Makefile
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2018-03-03 01:38:50 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2018-03-03 12:58:55 +0100
commit4d90887496b43b1db9f48ccdc9fe823b5371e323 (patch)
tree89d9b519a21732e1a16b74a360d14d30a44515fb /package/kernel/lantiq/ltq-adsl/Makefile
parentb5c5f7d203aae4b9531e423f593f80f7c9445ea3 (diff)
downloadupstream-4d90887496b43b1db9f48ccdc9fe823b5371e323.tar.gz
upstream-4d90887496b43b1db9f48ccdc9fe823b5371e323.tar.bz2
upstream-4d90887496b43b1db9f48ccdc9fe823b5371e323.zip
lantiq: ltq-adsl: Do not leak user space CFLAGS into kernel space
Do not leak the user space CFLAGS into the kernel space any more, this allows us to activate the MIPS16 build. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'package/kernel/lantiq/ltq-adsl/Makefile')
-rw-r--r--package/kernel/lantiq/ltq-adsl/Makefile5
1 files changed, 1 insertions, 4 deletions
diff --git a/package/kernel/lantiq/ltq-adsl/Makefile b/package/kernel/lantiq/ltq-adsl/Makefile
index b6f1c8a96a..e6817efffc 100644
--- a/package/kernel/lantiq/ltq-adsl/Makefile
+++ b/package/kernel/lantiq/ltq-adsl/Makefile
@@ -10,14 +10,13 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=ltq-adsl
PKG_VERSION:=3.24.4.4
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=drv_dsl_cpe_api_danube-$(PKG_VERSION).tar.gz
PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/ltq-dsl-$(BUILD_VARIANT)/drv_dsl_cpe_api-$(PKG_VERSION)
PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources/
PKG_HASH:=eb2ed59715d3bf4e8a1460bbbe2f1660039e0a9f9d72afb1b2b16590094eb33c
PKG_MAINTAINER:=John Crispin <john@phrozen.org>
-PKG_USE_MIPS16:=0
PKG_CHECK_FORMAT_SECURITY:=0
PKG_FIXUP:=autoreconf
@@ -83,8 +82,6 @@ CONFIGURE_ARGS += \
EXTRA_CFLAGS += -DDEBUG
endif
-EXTRA_CFLAGS = -fno-pic -mno-abicalls -mlong-calls -G 0
-
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include/adsl
$(CP) $(PKG_BUILD_DIR)/src/include/drv_dsl_cpe_*.h $(1)/usr/include/adsl/