aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/hwmon-gsc/Makefile
diff options
context:
space:
mode:
authorTim Harvey <tharvey@gateworks.com>2023-02-27 16:11:33 -0800
committerHauke Mehrtens <hauke@hauke-m.de>2023-03-01 23:25:41 +0100
commit339a67cb7f2b32c156e0fcf79c59ba913e10c267 (patch)
tree3708a47e90b32d6149a0c088a84e4b6aed116406 /package/kernel/hwmon-gsc/Makefile
parent79bd0172ca5671f7cdf382dc80ec1630da057947 (diff)
downloadupstream-339a67cb7f2b32c156e0fcf79c59ba913e10c267.tar.gz
upstream-339a67cb7f2b32c156e0fcf79c59ba913e10c267.tar.bz2
upstream-339a67cb7f2b32c156e0fcf79c59ba913e10c267.zip
kernel: fix hwmon-gsc driver
Fix hwmon-gsc driver by replacing out-of-tree hwmon-gsc driver with in-tree driver that was merged in Linux v5.8: - remove the old out-of-tree module - add configuration for the in-tree modules Signed-off-by: Tim Harvey <tharvey@gateworks.com>
Diffstat (limited to 'package/kernel/hwmon-gsc/Makefile')
-rw-r--r--package/kernel/hwmon-gsc/Makefile28
1 files changed, 0 insertions, 28 deletions
diff --git a/package/kernel/hwmon-gsc/Makefile b/package/kernel/hwmon-gsc/Makefile
deleted file mode 100644
index cd7d4efb10..0000000000
--- a/package/kernel/hwmon-gsc/Makefile
+++ /dev/null
@@ -1,28 +0,0 @@
-include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/kernel.mk
-
-PKG_NAME:=hwmon-gsc
-PKG_RELEASE:=1
-
-include $(INCLUDE_DIR)/package.mk
-
-define KernelPackage/hwmon-gsc
- SUBMENU:=Hardware Monitoring Support
- DEPENDS:=@TARGET_imx +kmod-hwmon-core +kmod-i2c-core
- TITLE:=Driver for the Gateworks System Controller
- AUTOLOAD:=$(call AutoLoad,60,gsc)
- FILES:=$(PKG_BUILD_DIR)/gsc.ko
-endef
-
-define KernelPackage/hwmon-gsc/description
- Kernel module for the Gateworks System Controller chips.
-endef
-
-define Build/Compile
- $(KERNEL_MAKE) \
- M="$(PKG_BUILD_DIR)" \
- EXTRA_CFLAGS="$(BUILDFLAGS)" \
- modules
-endef
-
-$(eval $(call KernelPackage,hwmon-gsc))