aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/gpio-nct5104d/Makefile
diff options
context:
space:
mode:
authorChris Blake <chrisrblake93@gmail.com>2017-01-23 02:12:35 -0600
committerJo-Philipp Wich <jo@mein.io>2017-03-01 20:37:35 +0100
commit2b122a6750010b03945c48d60ab392852dbf4b8c (patch)
tree48b1473366c7f060142fc2d9fe48e56624cfaa97 /package/kernel/gpio-nct5104d/Makefile
parentbc443b105269192d336cacfcc062f61484d43216 (diff)
downloadupstream-2b122a6750010b03945c48d60ab392852dbf4b8c.tar.gz
upstream-2b122a6750010b03945c48d60ab392852dbf4b8c.tar.bz2
upstream-2b122a6750010b03945c48d60ab392852dbf4b8c.zip
gpio-nct5104d: Add nct5104d driver package
This adds support for the SuperIO chip nct5104d found on the PC Engines APU boards, which allows for a handful of additional ports, such as 2x additional UART pinouts, enabling an external watchdog (no driver for this functionality yet), and 16 GPIO pins. More info can be found at https://pcengines.ch/ht_gpio.htm Thanks to @feckert for helping package this. Cc: Florian Eckert <Eckert.Florian@googlemail.com> Signed-off-by: Chris Blake <chrisrblake93@gmail.com>
Diffstat (limited to 'package/kernel/gpio-nct5104d/Makefile')
-rw-r--r--package/kernel/gpio-nct5104d/Makefile52
1 files changed, 52 insertions, 0 deletions
diff --git a/package/kernel/gpio-nct5104d/Makefile b/package/kernel/gpio-nct5104d/Makefile
new file mode 100644
index 0000000000..b43291e5a4
--- /dev/null
+++ b/package/kernel/gpio-nct5104d/Makefile
@@ -0,0 +1,52 @@
+#
+# Copyright (C) 2017 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
+
+PKG_NAME:=gpio-nct5104d
+PKG_RELEASE:=1
+
+PKG_MAINTAINER:=Florian Eckert <Eckert.Florian@googlemail.com>
+PKG_LICENSE:=GPL-2.0
+
+include $(INCLUDE_DIR)/package.mk
+
+define KernelPackage/gpio-nct5104d
+ SUBMENU:=Other modules
+ TITLE:= GPIO nct5104d support
+ DEPENDS:= @GPIO_SUPPORT @TARGET_x86
+ FILES:=$(PKG_BUILD_DIR)/gpio-nct5104d.ko
+ AUTOLOAD:=$(call AutoLoad,30,gpio-nct5104d,1)
+ KCONFIG:=
+endef
+
+define KernelPackage/gpio-nct5104d/description
+ Support for GPIO functionality of NCT5104D super I/O chip.
+endef
+
+EXTRA_KCONFIG:= \
+ CONFIG_GPIO_NCT5104D=m
+
+EXTRA_CFLAGS:= \
+ $(patsubst CONFIG_%, -DCONFIG_%=1, $(patsubst %=m,%,$(filter %=m,$(EXTRA_KCONFIG)))) \
+ $(patsubst CONFIG_%, -DCONFIG_%=1, $(patsubst %=y,%,$(filter %=y,$(EXTRA_KCONFIG)))) \
+
+MAKE_OPTS:= \
+ ARCH="$(LINUX_KARCH)" \
+ CROSS_COMPILE="$(TARGET_CROSS)" \
+ SUBDIRS="$(PKG_BUILD_DIR)" \
+ EXTRA_CFLAGS="$(EXTRA_CFLAGS)" \
+ $(EXTRA_KCONFIG)
+
+define Build/Compile
+ $(MAKE) -C "$(LINUX_DIR)" \
+ $(MAKE_OPTS) \
+ modules
+endef
+
+$(eval $(call KernelPackage,gpio-nct5104d))