aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/broadcom-wl/Makefile
diff options
context:
space:
mode:
authorChristian Marangi <ansuelsmth@gmail.com>2023-05-10 15:45:49 +0200
committerChristian Marangi <ansuelsmth@gmail.com>2023-05-12 03:15:45 +0200
commit3ccdc15c6ab14df898d9f36f0d7fa752ac1c15d6 (patch)
treef5726e819a1e7a5c7d3d7586a82884b164b5d9f2 /package/kernel/broadcom-wl/Makefile
parent136059d72a0fd39d98ad66aba418bad00b4ed78a (diff)
downloadupstream-3ccdc15c6ab14df898d9f36f0d7fa752ac1c15d6.tar.gz
upstream-3ccdc15c6ab14df898d9f36f0d7fa752ac1c15d6.tar.bz2
upstream-3ccdc15c6ab14df898d9f36f0d7fa752ac1c15d6.zip
kernel: broadcom-wl: multiple fix to make the package compilable again
Add multiple patch to make the package compilable again. Aside from some fixup of obvius wrong code, some real fix were needed. This fix any compilation warning found on compiling the package on bcm47xx. (omitted since they are too much) The real problem of this package was the missing MODULE_LICENSE now mandatory even without WERROR. Set to Proprietary. And the big blocker is that Broadcom provided an object file targetting an old kernel version. The module on modprobe try to find the symbol printk but printk was dropped and replaced to _printk. To handle this change we use objcopy tool to rename the symbol to the new name permitting a correct modprobe and creation of .ko Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
Diffstat (limited to 'package/kernel/broadcom-wl/Makefile')
-rw-r--r--package/kernel/broadcom-wl/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/package/kernel/broadcom-wl/Makefile b/package/kernel/broadcom-wl/Makefile
index fe8045d4a9..a1feacbe29 100644
--- a/package/kernel/broadcom-wl/Makefile
+++ b/package/kernel/broadcom-wl/Makefile
@@ -105,6 +105,15 @@ MAKE_KMOD := $(KERNEL_MAKE) \
define Build/Prepare
$(call Build/Prepare/Default)
+
+ # New kernel version changed the sysmbol exported from printk to _printk
+ # The object file provided by broadcom require modification to correctly
+ # modprobe and generate a .ko
+ $(TARGET_CROSS)objcopy $(PKG_BUILD_DIR)/driver/wl_apsta/wl_prebuilt.o \
+ --redefine-sym printk=_printk
+ $(TARGET_CROSS)objcopy $(PKG_BUILD_DIR)/driver/wl_apsta_mini/wl_prebuilt.o \
+ --redefine-sym printk=_printk
+
$(CP) $(PKG_BUILD_DIR)/driver $(PKG_BUILD_DIR)/driver-mini
$(CP) ./src/glue $(PKG_BUILD_DIR)/glue
endef