aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/ath10k-ct/patches
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2018-01-10 21:46:46 +0100
committerMatthias Schiffer <mschiffer@universe-factory.net>2018-01-13 19:54:45 +0100
commite9fa0b9f3ae0711dd07d61b482f6bdb6446b4f9c (patch)
tree4dff3ca5737661ab76954d1193cf58c5e537ffb6 /package/kernel/ath10k-ct/patches
parentde0ccd35323b420e96ac849b327e77dd9c7837b0 (diff)
downloadupstream-e9fa0b9f3ae0711dd07d61b482f6bdb6446b4f9c.tar.gz
upstream-e9fa0b9f3ae0711dd07d61b482f6bdb6446b4f9c.tar.bz2
upstream-e9fa0b9f3ae0711dd07d61b482f6bdb6446b4f9c.zip
ath9k, ath10k(-ct): move spectral scan support under a separate config symbol
Backport patches that separate spectral scan support from general debugfs support of ath9k/ath10k; this allows to remove the dependency on KERNEL_RELAY from these driver packages even with debugfs enabled and avoids the memory footprint of the relay buffers allocated by ath9k/ath10k even when they aren't used at all. The KERNEL_RELAY dependency is moved to a new config symbol that enables spectral scan support in these drivers. Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
Diffstat (limited to 'package/kernel/ath10k-ct/patches')
-rw-r--r--package/kernel/ath10k-ct/patches/200-ath10k-move-spectral-scan-support-under-a-separate-c.patch81
1 files changed, 81 insertions, 0 deletions
diff --git a/package/kernel/ath10k-ct/patches/200-ath10k-move-spectral-scan-support-under-a-separate-c.patch b/package/kernel/ath10k-ct/patches/200-ath10k-move-spectral-scan-support-under-a-separate-c.patch
new file mode 100644
index 0000000000..bdc82f0067
--- /dev/null
+++ b/package/kernel/ath10k-ct/patches/200-ath10k-move-spectral-scan-support-under-a-separate-c.patch
@@ -0,0 +1,81 @@
+From 42e01cb9cb109fb0bb4743f6c54d6aa67ac39b61 Mon Sep 17 00:00:00 2001
+Message-Id: <42e01cb9cb109fb0bb4743f6c54d6aa67ac39b61.1515610034.git.mschiffer@universe-factory.net>
+In-Reply-To: <9df7ddc3ed25b7d3473f117a0680b9418adb5753.1515610034.git.mschiffer@universe-factory.net>
+References: <9df7ddc3ed25b7d3473f117a0680b9418adb5753.1515610034.git.mschiffer@universe-factory.net>
+From: Matthias Schiffer <mschiffer@universe-factory.net>
+Date: Mon, 27 Nov 2017 18:56:23 +0100
+Subject: [PATCH 2/2] ath10k: move spectral scan support under a separate
+ config symbol
+
+At the moment, spectral scan support, and with it RELAY, is always enabled
+with ATH10K_DEBUGFS. Spectral scan support is currently the only user of
+RELAY in ath10k, and it unconditionally reserves a relay channel.
+
+Having debugfs support in ath10k is often useful even on very small
+embedded routers, where we'd rather like to avoid the code size and RAM
+usage of the relay support. While ath10k-based devices usually have more
+resources than ath9k-based ones, it makes sense to keep the configuration
+symmetric to ath9k, so the same base kernel without RELAY can be used for
+both ath9k and ath10k hardware.
+
+Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
+Signed-off-by: Kalle Valo <kvalo@qca.qualcomm.com>
+---
+ ath10k-4.13/Kconfig | 9 ++++++++-
+ ath10k-4.13/Makefile | 2 +-
+ ath10k-4.13/spectral.h | 4 ++--
+ 3 files changed, 11 insertions(+), 4 deletions(-)
+
+--- a/ath10k-4.13/Kconfig
++++ b/ath10k-4.13/Kconfig
+@@ -40,12 +40,19 @@ config ATH10K_DEBUG
+ config ATH10K_DEBUGFS
+ bool "Atheros ath10k debugfs support"
+ depends on ATH10K && DEBUG_FS
+- select RELAY
+ ---help---
+ Enabled debugfs support
+
+ If unsure, say Y to make it easier to debug problems.
+
++config ATH10K_SPECTRAL
++ bool "Atheros ath10k spectral scan support"
++ depends on ATH10K_DEBUGFS
++ select RELAY
++ default n
++ ---help---
++ Say Y to enable access to the FFT/spectral data via debugfs.
++
+ config ATH10K_TRACING
+ bool "Atheros ath10k tracing support"
+ depends on ATH10K
+--- a/ath10k-4.13/Makefile
++++ b/ath10k-4.13/Makefile
+@@ -14,7 +14,7 @@ ath10k_core-y += mac.o \
+ p2p.o \
+ swap.o
+
+-ath10k_core-$(CONFIG_ATH10K_DEBUGFS) += spectral.o
++ath10k_core-$(CONFIG_ATH10K_SPECTRAL) += spectral.o
+ ath10k_core-$(CONFIG_NL80211_TESTMODE) += testmode.o
+ ath10k_core-$(CONFIG_ATH10K_TRACING) += trace.o
+ ath10k_core-$(CONFIG_THERMAL) += thermal.o
+--- a/ath10k-4.13/spectral.h
++++ b/ath10k-4.13/spectral.h
+@@ -44,7 +44,7 @@ enum ath10k_spectral_mode {
+ SPECTRAL_MANUAL,
+ };
+
+-#ifdef CONFIG_ATH10K_DEBUGFS
++#ifdef CONFIG_ATH10K_SPECTRAL
+
+ int ath10k_spectral_process_fft(struct ath10k *ar,
+ struct wmi_phyerr_ev_arg *phyerr,
+@@ -85,6 +85,6 @@ static inline void ath10k_spectral_destr
+ {
+ }
+
+-#endif /* CONFIG_ATH10K_DEBUGFS */
++#endif /* CONFIG_ATH10K_SPECTRAL */
+
+ #endif /* SPECTRAL_H */