aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/ath10k-ct/patches/200-ath10k-move-spectral-scan-support-under-a-separate-c.patch
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2019-07-07 13:38:37 +0200
committerKoen Vandeputte <koen.vandeputte@ncentric.com>2019-08-27 10:31:06 +0200
commit5c47bfb735cdfaa52203a35b157cdabce75242b3 (patch)
tree9b01737bb5fb21906c4f9ece430337f944db6fc5 /package/kernel/ath10k-ct/patches/200-ath10k-move-spectral-scan-support-under-a-separate-c.patch
parent218cc22a43280c1d7bcbe6d0160f1cef77e3ecd8 (diff)
downloadupstream-5c47bfb735cdfaa52203a35b157cdabce75242b3.tar.gz
upstream-5c47bfb735cdfaa52203a35b157cdabce75242b3.tar.bz2
upstream-5c47bfb735cdfaa52203a35b157cdabce75242b3.zip
ath10k-ct: remove patches for old versions
the ath10k-ct package ships multiple versions of the ath10k-ct driver, OpenWrt currently only uses the version 4.19, but we still ship some patches for older versions. Remove all patches only touching older versions and also remove the patch for older versions from patches which do the same changes to multiple versions of ath10k-ct. This removes some unneeded patches, the end binary should stay the same. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> (cherry picked from commit 10fe5ca3629c4739763df0274610b43eebd1ee3a)
Diffstat (limited to 'package/kernel/ath10k-ct/patches/200-ath10k-move-spectral-scan-support-under-a-separate-c.patch')
-rw-r--r--package/kernel/ath10k-ct/patches/200-ath10k-move-spectral-scan-support-under-a-separate-c.patch81
1 files changed, 0 insertions, 81 deletions
diff --git a/package/kernel/ath10k-ct/patches/200-ath10k-move-spectral-scan-support-under-a-separate-c.patch b/package/kernel/ath10k-ct/patches/200-ath10k-move-spectral-scan-support-under-a-separate-c.patch
deleted file mode 100644
index bdc82f0067..0000000000
--- a/package/kernel/ath10k-ct/patches/200-ath10k-move-spectral-scan-support-under-a-separate-c.patch
+++ /dev/null
@@ -1,81 +0,0 @@
-From 42e01cb9cb109fb0bb4743f6c54d6aa67ac39b61 Mon Sep 17 00:00:00 2001
-Message-Id: <42e01cb9cb109fb0bb4743f6c54d6aa67ac39b61.1515610034.git.mschiffer@universe-factory.net>
-In-Reply-To: <9df7ddc3ed25b7d3473f117a0680b9418adb5753.1515610034.git.mschiffer@universe-factory.net>
-References: <9df7ddc3ed25b7d3473f117a0680b9418adb5753.1515610034.git.mschiffer@universe-factory.net>
-From: Matthias Schiffer <mschiffer@universe-factory.net>
-Date: Mon, 27 Nov 2017 18:56:23 +0100
-Subject: [PATCH 2/2] ath10k: move spectral scan support under a separate
- config symbol
-
-At the moment, spectral scan support, and with it RELAY, is always enabled
-with ATH10K_DEBUGFS. Spectral scan support is currently the only user of
-RELAY in ath10k, and it unconditionally reserves a relay channel.
-
-Having debugfs support in ath10k is often useful even on very small
-embedded routers, where we'd rather like to avoid the code size and RAM
-usage of the relay support. While ath10k-based devices usually have more
-resources than ath9k-based ones, it makes sense to keep the configuration
-symmetric to ath9k, so the same base kernel without RELAY can be used for
-both ath9k and ath10k hardware.
-
-Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
-Signed-off-by: Kalle Valo <kvalo@qca.qualcomm.com>
----
- ath10k-4.13/Kconfig | 9 ++++++++-
- ath10k-4.13/Makefile | 2 +-
- ath10k-4.13/spectral.h | 4 ++--
- 3 files changed, 11 insertions(+), 4 deletions(-)
-
---- a/ath10k-4.13/Kconfig
-+++ b/ath10k-4.13/Kconfig
-@@ -40,12 +40,19 @@ config ATH10K_DEBUG
- config ATH10K_DEBUGFS
- bool "Atheros ath10k debugfs support"
- depends on ATH10K && DEBUG_FS
-- select RELAY
- ---help---
- Enabled debugfs support
-
- If unsure, say Y to make it easier to debug problems.
-
-+config ATH10K_SPECTRAL
-+ bool "Atheros ath10k spectral scan support"
-+ depends on ATH10K_DEBUGFS
-+ select RELAY
-+ default n
-+ ---help---
-+ Say Y to enable access to the FFT/spectral data via debugfs.
-+
- config ATH10K_TRACING
- bool "Atheros ath10k tracing support"
- depends on ATH10K
---- a/ath10k-4.13/Makefile
-+++ b/ath10k-4.13/Makefile
-@@ -14,7 +14,7 @@ ath10k_core-y += mac.o \
- p2p.o \
- swap.o
-
--ath10k_core-$(CONFIG_ATH10K_DEBUGFS) += spectral.o
-+ath10k_core-$(CONFIG_ATH10K_SPECTRAL) += spectral.o
- ath10k_core-$(CONFIG_NL80211_TESTMODE) += testmode.o
- ath10k_core-$(CONFIG_ATH10K_TRACING) += trace.o
- ath10k_core-$(CONFIG_THERMAL) += thermal.o
---- a/ath10k-4.13/spectral.h
-+++ b/ath10k-4.13/spectral.h
-@@ -44,7 +44,7 @@ enum ath10k_spectral_mode {
- SPECTRAL_MANUAL,
- };
-
--#ifdef CONFIG_ATH10K_DEBUGFS
-+#ifdef CONFIG_ATH10K_SPECTRAL
-
- int ath10k_spectral_process_fft(struct ath10k *ar,
- struct wmi_phyerr_ev_arg *phyerr,
-@@ -85,6 +85,6 @@ static inline void ath10k_spectral_destr
- {
- }
-
--#endif /* CONFIG_ATH10K_DEBUGFS */
-+#endif /* CONFIG_ATH10K_SPECTRAL */
-
- #endif /* SPECTRAL_H */