aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/ath10k-ct/Makefile
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2018-01-10 21:46:46 +0100
committerMatthias Schiffer <mschiffer@universe-factory.net>2018-01-13 19:54:45 +0100
commite9fa0b9f3ae0711dd07d61b482f6bdb6446b4f9c (patch)
tree4dff3ca5737661ab76954d1193cf58c5e537ffb6 /package/kernel/ath10k-ct/Makefile
parentde0ccd35323b420e96ac849b327e77dd9c7837b0 (diff)
downloadupstream-e9fa0b9f3ae0711dd07d61b482f6bdb6446b4f9c.tar.gz
upstream-e9fa0b9f3ae0711dd07d61b482f6bdb6446b4f9c.tar.bz2
upstream-e9fa0b9f3ae0711dd07d61b482f6bdb6446b4f9c.zip
ath9k, ath10k(-ct): move spectral scan support under a separate config symbol
Backport patches that separate spectral scan support from general debugfs support of ath9k/ath10k; this allows to remove the dependency on KERNEL_RELAY from these driver packages even with debugfs enabled and avoids the memory footprint of the relay buffers allocated by ath9k/ath10k even when they aren't used at all. The KERNEL_RELAY dependency is moved to a new config symbol that enables spectral scan support in these drivers. Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
Diffstat (limited to 'package/kernel/ath10k-ct/Makefile')
-rw-r--r--package/kernel/ath10k-ct/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/package/kernel/ath10k-ct/Makefile b/package/kernel/ath10k-ct/Makefile
index 82d7664b76..fe094e76a3 100644
--- a/package/kernel/ath10k-ct/Makefile
+++ b/package/kernel/ath10k-ct/Makefile
@@ -1,7 +1,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=ath10k-ct
-PKG_RELEASE=1
+PKG_RELEASE=2
PKG_LICENSE:=GPLv2
PKG_LICENSE_FILES:=
@@ -29,7 +29,7 @@ include $(INCLUDE_DIR)/package.mk
define KernelPackage/ath10k-ct
SUBMENU:=Wireless Drivers
TITLE:=ath10k-ct driver optimized for CT ath10k firmware
- DEPENDS:=+kmod-mac80211 +kmod-ath +@DRIVER_11N_SUPPORT +@DRIVER_11AC_SUPPORT @PCI_SUPPORT +@KERNEL_RELAY +kmod-hwmon-core
+ DEPENDS:=+kmod-mac80211 +kmod-ath +@DRIVER_11N_SUPPORT +@DRIVER_11AC_SUPPORT @PCI_SUPPORT +kmod-hwmon-core
FILES:=\
$(PKG_BUILD_DIR)/ath10k$(CT_KVER)/ath10k_pci.ko \
$(PKG_BUILD_DIR)/ath10k$(CT_KVER)/ath10k_core.ko
@@ -69,6 +69,11 @@ ifdef CONFIG_PACKAGE_ATH_DFS
NOSTDINC_FLAGS += -DCONFIG_ATH10K_DFS_CERTIFIED
endif
+ifdef CONFIG_PACKAGE_ATH_SPECTRAL
+ CT_MAKEDEFS += CONFIG_ATH10K_SPECTRAL=y
+ NOSTDINC_FLAGS += -DCONFIG_ATH10K_SPECTRAL
+endif
+
define Build/Configure
cp $(STAGING_DIR)/usr/include/mac80211/ath/*.h $(PKG_BUILD_DIR)
endef