aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/acx-mac80211
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2022-10-12 12:54:30 +0200
committerFelix Fietkau <nbd@nbd.name>2022-11-09 20:44:28 +0100
commita06e023b4e124dad2b2ddf3db87cb804b7043b26 (patch)
tree64a3dfcbc4ae2692c2670f37392e7955dc5d8c56 /package/kernel/acx-mac80211
parentf753316f4aa4764e80c4dbf6f2cc88922052da1e (diff)
downloadupstream-a06e023b4e124dad2b2ddf3db87cb804b7043b26.tar.gz
upstream-a06e023b4e124dad2b2ddf3db87cb804b7043b26.tar.bz2
upstream-a06e023b4e124dad2b2ddf3db87cb804b7043b26.zip
mac80211: remove old legacy legacy drivers
Get rid of drivers that are either limited to 802.11b/g or don't even support cfg80211/mac80211. Most of these are either limited to boards that we don't even support anymore because of firmware size, or were only used for custom hacks by a really small number of users in the past. Let's get rid of those to reduce the maintenance effort and the number of useless packages Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/kernel/acx-mac80211')
-rw-r--r--package/kernel/acx-mac80211/Makefile255
-rw-r--r--package/kernel/acx-mac80211/patches/100-compat.patch16
-rw-r--r--package/kernel/acx-mac80211/patches/200-initial-macaddr.patch29
-rw-r--r--package/kernel/acx-mac80211/patches/300-api_sync.patch112
4 files changed, 0 insertions, 412 deletions
diff --git a/package/kernel/acx-mac80211/Makefile b/package/kernel/acx-mac80211/Makefile
deleted file mode 100644
index 240f171d1e..0000000000
--- a/package/kernel/acx-mac80211/Makefile
+++ /dev/null
@@ -1,255 +0,0 @@
-#
-# Copyright (C) 2007-2012 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/kernel.mk
-
-PKG_NAME:=acx-mac80211
-PKG_RELEASE:=1
-
-PKG_SOURCE_URL:=http://git.code.sf.net/p/acx100/acx-mac80211
-PKG_SOURCE_PROTO:=git
-PKG_SOURCE_DATE:=2014-02-16
-PKG_SOURCE_VERSION:=b6fc31491020cb01d2cd1acc170cfa03ced7e726
-PKG_MIRROR_HASH:=58590245715f0e5fb4b57aab6d91071dfb6a97d3273f5aee0b97b1edee030ed0
-
-DL_SUBDIR:=$(PKG_NAME)-$(PKG_SOURCE_DATE)
-
-PKG_CONFIG_DEPENDS:= \
- CONFIG_PACKAGE_MAC80211_DEBUGFS \
- CONFIG_PACKAGE_MAC80211_MESH \
-
-include $(INCLUDE_DIR)/package.mk
-
-define KernelPackage/acx-mac80211
- SUBMENU:=Wireless Drivers
- TITLE:=ACX1xx mac80211 driver
- DEPENDS:=@PCI_SUPPORT @mipsel +kmod-mac80211
- FILES:=$(PKG_BUILD_DIR)/acx-mac80211.ko
- AUTOLOAD:=$(call AutoProbe,acx-mac80211)
- MENU:=1
-endef
-
-define KernelPackage/acx-mac80211/config
- menu "Configuration"
- depends on PACKAGE_kmod-acx-mac80211
-
- config ACX_ID_0D
- bool "ACX1xx Radio ID 0D firmware"
- help
- Download and install firmware for:
- ACX1xx cards with Radio ID 0D into /lib/firmware.
-
- config ACX_ID_11
- bool "ACX1xx Radio ID 11 firmware"
- help
- Download and install firmware for:
- ACX1xx cards with Radio ID 11 into /lib/firmware.
-
- config ACX_ID_15
- bool "ACX1xx Radio ID 15 firmware"
- help
- Download and install firmware for:
- ACX1xx cards with Radio ID 15 into /lib/firmware.
-
- config ACX_ID_16
- bool "ACX1xx Radio ID 16 firmware"
- default y
- help
- Download and install firmware for:
- ACX1xx cards with Radio ID 16 into /lib/firmware.
-
- choice
- prompt "ACX111 firmware version"
- depends on ACX_ID_16
- default ACX_DEFAULT
- help
- This option allows you to select the version of the acx firmware.
-
- config ACX_DEFAULT
- bool "Default"
- help
- Default firmware for ACX111 devices.
-
- If unsure, select this.
-
- config ACX_1_2_1_34
- bool "1.2.1_34"
- help
- 1.2.1_34 firmware for ACX111 devices. Works with Zyxel P-334WT.
-
- If unsure, select the "default" firmware.
-
- endchoice
-
- config ACX_ID_17
- bool "ACX1xx Radio ID 17 firmware"
- help
- Download and install firmware for:
- ACX1xx cards with Radio ID 17 into /lib/firmware.
-
- config ACX_ID_19
- bool "ACX1xx Radio ID 19 firmware"
- default y
- help
- Download and install firmware for:
- ACX1xx cards with Radio ID 19 into /lib/firmware.
-
- config ACX_ID_1B
- bool "ACX1xx Radio ID 1B firmware"
- help
- Download and install firmware for:
- ACX1xx cards with Radio ID 1b into /lib/firmware.
-
- endmenu
-endef
-
-define KernelPackage/acx-mac80211/description
- Driver for acx111 cards (mac80211 version)
-endef
-
-define Download/tiacx100
- FILE:=tiacx100
- URL:=@OPENWRT
- HASH:=4f05913c940c2455b267545b12d93ad81fa5eebb0cbee22a2c7588c50525b4f0
-endef
-
-define Download/tiacx100r0d
- FILE:=tiacx100r0D
- URL:=@OPENWRT
- HASH:=6a4a7fbb24a328a88261bc2a507b2a0bf63c91e831e3f1a8caa4f6599b2215e6
-endef
-
-define Download/tiacx100r11
- FILE:=tiacx100r11
- URL:=@OPENWRT
- HASH:=e005a93a0b463e01edba2b79038b54c29a7932efee61c851a2ac644b8a4e5dd4
-endef
-
-define Download/tiacx100r15
- FILE:=tiacx100r15
- URL:=@OPENWRT
- HASH:=c6f40bead5ef45720e2d72bbe4d998367c2c7857eb7716234aedeb2ad98bcdde
-endef
-
-define Download/tiacx111c16
- FILE:=tiacx111c16
- URL:=@OPENWRT
- HASH:=cc6108d577ebc55b924ff6bab44eeee3456d284c63819277cb5460338b2f1bd7
-endef
-
-define Download/tiacx111c16_1
- FILE:=tiacx111c16_1.2.1_34
- URL:=@OPENWRT
- HASH:=672ed9d02565ab44da450c52f0ced3be99a3a3901f73454455da8e1f98ada220
-endef
-
-define Download/tiacx111c17
- FILE:=tiacx111c17
- URL:=@OPENWRT
- HASH:=2bb900a5886dbea2d3504623d9f3ac8abbb2e9fdfcf0fe233e77951dff748a40
-endef
-
-define Download/tiacx111c19
- FILE:=tiacx111c19
- URL:=@OPENWRT
- HASH:=383d86a8cfddf92400d661b4e43a9b855350fa656edd4f75b4aff7fab2d00e90
-endef
-
-define Download/tiacx111usbc1b
- FILE:=tiacx111usbc1B
- URL:=@OPENWRT
- HASH:=f3c9e574de7073014ab6eef9a0f6412c53ae521b67723360af753c41401ed4d5
-endef
-
-PKG_EXTRA_KCONFIG:= \
- CONFIG_ACX_MAC80211=m \
- CONFIG_ACX_MAC80211_PCI=m \
-
-PKG_EXTRA_CFLAGS:= \
- $(patsubst CONFIG_%, -DCONFIG_%=1, $(patsubst %=m,%,$(filter %=m,$(PKG_EXTRA_KCONFIG)))) \
- $(patsubst CONFIG_%, -DCONFIG_%=1, $(patsubst %=y,%,$(filter %=y,$(PKG_EXTRA_KCONFIG)))) \
- $(if $(CONFIG_LEDS_TRIGGERS), -DCONFIG_MAC80211_LEDS -DCONFIG_LEDS_TRIGGERS) \
- $(if $(CONFIG_PACKAGE_MAC80211_DEBUGFS), -DCONFIG_CFG80211_DEBUGFS -DCONFIG_MAC80211_DEBUGFS) \
- $(if $(CONFIG_PACKAGE_MAC80211_MESH), -DCONFIG_MAC80211_MESH) \
- -DBACKPORTED_KERNEL_NAME=\\\"$(PKG_SOURCE)\\\" \
- -DBACKPORTED_KERNEL_VERSION=\\\"$(PKG_SOURCE_VERSION)\\\" \
- -DBACKPORTS_VERSION=\\\"unknown\\\" \
-
-define Build/Compile
- $(MAKE) -C "$(LINUX_DIR)" \
- $(KERNEL_MAKE_FLAGS) \
- M="$(PKG_BUILD_DIR)" \
- $(PKG_EXTRA_KCONFIG) \
- EXTRA_CFLAGS="$(PKG_EXTRA_CFLAGS) -DCONFIG_ACX_MAC80211_VERSION=\"KERNEL_VERSION(4,2,0)\"" \
- LINUXINCLUDE="-I$(STAGING_DIR)/usr/include/mac80211-backport/uapi -I$(STAGING_DIR)/usr/include/mac80211-backport \
- -I$(STAGING_DIR)/usr/include/mac80211/uapi -I$(STAGING_DIR)/usr/include/mac80211 \
- -I$(LINUX_DIR)/include -I$(LINUX_DIR)/include/$(LINUX_UAPI_DIR) \
- -I$(LINUX_DIR)/include/generated/uapi/ -Iarch/$(LINUX_KARCH)/include \
- -Iarch/$(LINUX_KARCH)/include/$(LINUX_UAPI_DIR) \
- -Iarch/$(LINUX_KARCH)/include/generated \
- -Iarch/$(LINUX_KARCH)/include/generated/$(LINUX_UAPI_DIR) \
- -include generated/autoconf.h \
- -include backport/backport.h " \
- V="$(V)" \
- modules
-endef
-
-define Build/Configure
-endef
-
-define KernelPackage/acx-mac80211/install
- $(INSTALL_DIR) $(1)/lib/firmware
-
-ifneq ($(CONFIG_ACX_ID_0D)$(CONFIG_ACX_ID_11)$(CONFIG_ACX_ID_15),)
- $(INSTALL_DATA) $(DL_DIR)/tiacx100 $(1)/lib/firmware/
-endif
-
-ifneq ($(CONFIG_ACX_ID_0D),)
- $(INSTALL_DATA) $(DL_DIR)/tiacx100r0D $(1)/lib/firmware/
-endif
-
-ifneq ($(CONFIG_ACX_ID_11),)
- $(INSTALL_DATA) $(DL_DIR)/tiacx100r11 $(1)/lib/firmware/
-endif
-
-ifneq ($(CONFIG_ACX_ID_15),)
- $(INSTALL_DATA) $(DL_DIR)/tiacx100r15 $(1)/lib/firmware/
-endif
-
-ifneq ($(CONFIG_ACX_DEFAULT),)
- $(INSTALL_DATA) $(DL_DIR)/tiacx111c16 $(1)/lib/firmware/
-endif
-
-ifneq ($(CONFIG_ACX_1_2_1_34),)
- $(INSTALL_DATA) $(DL_DIR)/tiacx111c16_1.2.1_34 $(1)/lib/firmware/tiacx111c16
-endif
-
-ifneq ($(CONFIG_ACX_ID_17),)
- $(INSTALL_DATA) $(DL_DIR)/tiacx111c17 $(1)/lib/firmware/
-endif
-
-ifneq ($(CONFIG_ACX_ID_19),)
- $(INSTALL_DATA) $(DL_DIR)/tiacx111c19 $(1)/lib/firmware/
-endif
-
-ifneq ($(CONFIG_ACX_ID_1B),)
- $(INSTALL_DATA) $(DL_DIR)/tiacx111usbc1B $(1)/lib/firmware/
-endif
-
-endef
-
-$(eval $(call KernelPackage,acx-mac80211))
-$(eval $(call Download,tiacx100))
-$(eval $(call Download,tiacx100r0d))
-$(eval $(call Download,tiacx100r11))
-$(eval $(call Download,tiacx100r15))
-$(eval $(call Download,tiacx111c16))
-$(eval $(call Download,tiacx111c16_1))
-$(eval $(call Download,tiacx111c17))
-$(eval $(call Download,tiacx111c19))
-$(eval $(call Download,tiacx111usbc1b))
diff --git a/package/kernel/acx-mac80211/patches/100-compat.patch b/package/kernel/acx-mac80211/patches/100-compat.patch
deleted file mode 100644
index 6fcab5ea43..0000000000
--- a/package/kernel/acx-mac80211/patches/100-compat.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-diff --git a/pci.c b/pci.c
-index ae07f5a..72d542f 100644
---- a/pci.c
-+++ b/pci.c
-@@ -1495,7 +1495,11 @@ static struct acxpci_device_info acxpci_info_tbl[] __devinitdata = {
- #endif
-
- #ifdef CONFIG_PCI
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(4, 8, 0)
- static DEFINE_PCI_DEVICE_TABLE(acxpci_id_tbl) = {
-+#else
-+static const struct pci_device_id acxpci_id_tbl[] = {
-+#endif
- { PCI_VDEVICE(TI, PCI_DEVICE_ID_TI_TNETW1100A),
- .driver_data = CHIPTYPE_ACX100,
- },
diff --git a/package/kernel/acx-mac80211/patches/200-initial-macaddr.patch b/package/kernel/acx-mac80211/patches/200-initial-macaddr.patch
deleted file mode 100644
index c0fdd433b3..0000000000
--- a/package/kernel/acx-mac80211/patches/200-initial-macaddr.patch
+++ /dev/null
@@ -1,29 +0,0 @@
---- a/cardsetting.c
-+++ b/cardsetting.c
-@@ -715,10 +715,25 @@ int acx1xx_get_station_id(acx_device_t *
- u8 *stationID = adev->ie_cmd_buf;
- const u8 *paddr;
- int i, res;
-+ const char *prom_addr;
-+ char *prom_getenv(const char *name);
-
- res = acx_interrogate(adev, stationID, ACX1xx_IE_DOT11_STATION_ID);
- paddr = &stationID[4];
-- for (i = 0; i < ETH_ALEN; i++) {
-+ prom_addr = NULL;
-+#ifdef CONFIG_VLYNQ
-+ prom_addr = prom_getenv("macwlan");
-+ if (prom_addr == NULL)
-+ prom_addr = prom_getenv("mac_ap");
-+#endif
-+ if (prom_addr)
-+ sscanf(prom_addr, "%hhx:%hhx:%hhx:%hhx:%hhx:%hhx", adev->dev_addr,
-+ adev->dev_addr + 1,
-+ adev->dev_addr + 2,
-+ adev->dev_addr + 3,
-+ adev->dev_addr + 4,
-+ adev->dev_addr + 5);
-+ else for (i = 0; i < ETH_ALEN; i++) {
- /* we copy the MAC address (reversed in the card) to
- * the netdevice's MAC address, and on ifup it will be
- * copied into iwadev->dev_addr */
diff --git a/package/kernel/acx-mac80211/patches/300-api_sync.patch b/package/kernel/acx-mac80211/patches/300-api_sync.patch
deleted file mode 100644
index d055271f60..0000000000
--- a/package/kernel/acx-mac80211/patches/300-api_sync.patch
+++ /dev/null
@@ -1,112 +0,0 @@
---- a/main.c
-+++ b/main.c
-@@ -497,7 +497,7 @@ int acx_free_mechanics(acx_device_t *ade
-
- int acx_init_ieee80211(acx_device_t *adev, struct ieee80211_hw *hw)
- {
-- hw->flags &= ~IEEE80211_HW_RX_INCLUDES_FCS;
-+ __clear_bit(IEEE80211_HW_RX_INCLUDES_FCS, hw->flags);
- hw->queues = 1;
- hw->wiphy->max_scan_ssids = 1;
-
-@@ -525,14 +525,14 @@ int acx_init_ieee80211(acx_device_t *ade
- /* We base signal quality on winlevel approach of previous driver
- * TODO OW 20100615 This should into a common init code
- */
-- hw->flags |= IEEE80211_HW_SIGNAL_UNSPEC;
-+ __set_bit(IEEE80211_HW_SIGNAL_UNSPEC, hw->flags);
- hw->max_signal = 100;
-
- if (IS_ACX100(adev)) {
-- adev->hw->wiphy->bands[IEEE80211_BAND_2GHZ] =
-+ adev->hw->wiphy->bands[NL80211_BAND_2GHZ] =
- &acx100_band_2GHz;
- } else if (IS_ACX111(adev))
-- adev->hw->wiphy->bands[IEEE80211_BAND_2GHZ] =
-+ adev->hw->wiphy->bands[NL80211_BAND_2GHZ] =
- &acx111_band_2GHz;
- else {
- log(L_ANY, "Error: Unknown device");
-@@ -945,8 +945,8 @@ void acx_op_configure_filter(struct ieee
- changed_flags, *total_flags);
-
- /* OWI TODO: Set also FIF_PROBE_REQ ? */
-- *total_flags &= (FIF_PROMISC_IN_BSS | FIF_ALLMULTI | FIF_FCSFAIL
-- | FIF_CONTROL | FIF_OTHER_BSS);
-+ *total_flags &= (FIF_ALLMULTI | FIF_FCSFAIL | FIF_CONTROL
-+ | FIF_OTHER_BSS);
-
- logf1(L_DEBUG, "2: *total_flags=0x%08x\n", *total_flags);
-
-@@ -1045,9 +1045,10 @@ void acx_op_tx(struct ieee80211_hw *hw,
- }
-
- int acx_op_hw_scan(struct ieee80211_hw *hw, struct ieee80211_vif *vif,
-- struct cfg80211_scan_request *req)
-+ struct ieee80211_scan_request *hw_req)
- {
- acx_device_t *adev = hw2adev(hw);
-+ struct cfg80211_scan_request *req = &hw_req->req;
- struct sk_buff *skb;
- size_t ssid_len = 0;
- u8 *ssid = NULL;
-@@ -1082,7 +1083,7 @@ int acx_op_hw_scan(struct ieee80211_hw *
- goto out;
- }
- #else
-- skb = ieee80211_probereq_get(adev->hw, adev->vif, ssid, ssid_len,
-+ skb = ieee80211_probereq_get(adev->hw, vif->addr, ssid, ssid_len,
- req->ie_len);
- if (!skb) {
- ret = -ENOMEM;
---- a/main.h
-+++ b/main.h
-@@ -62,7 +62,7 @@ void acx_op_tx(struct ieee80211_hw *hw,
- #endif
-
- int acx_op_hw_scan(struct ieee80211_hw *hw, struct ieee80211_vif *vif,
-- struct cfg80211_scan_request *req);
-+ struct ieee80211_scan_request *req);
-
- int acx_recover_hw(acx_device_t *adev);
-
---- a/cardsetting.c
-+++ b/cardsetting.c
-@@ -159,7 +159,7 @@ int acx_set_channel(acx_device_t *adev,
- int res = 0;
-
- adev->rx_status.freq = freq;
-- adev->rx_status.band = IEEE80211_BAND_2GHZ;
-+ adev->rx_status.band = NL80211_BAND_2GHZ;
-
- adev->channel = channel;
-
---- a/merge.c
-+++ b/merge.c
-@@ -2776,7 +2776,10 @@ void acx_irq_work(struct work_struct *wo
- /* HOST_INT_SCAN_COMPLETE */
- if (irqmasked & HOST_INT_SCAN_COMPLETE) {
- if (test_bit(ACX_FLAG_SCANNING, &adev->flags)) {
-- ieee80211_scan_completed(adev->hw, false);
-+ struct cfg80211_scan_info info = {
-+ .aborted = false
-+ };
-+ ieee80211_scan_completed(adev->hw, &info);
- log(L_INIT, "scan completed\n");
- clear_bit(ACX_FLAG_SCANNING, &adev->flags);
- }
-@@ -3138,10 +3141,13 @@ int acx_op_start(struct ieee80211_hw *hw
-
- void acx_stop(acx_device_t *adev)
- {
-+ struct cfg80211_scan_info info = {
-+ .aborted = true
-+ };
- acxmem_lock_flags;
-
- if (test_bit(ACX_FLAG_SCANNING, &adev->flags)) {
-- ieee80211_scan_completed(adev->hw, true);
-+ ieee80211_scan_completed(adev->hw, &info);
- acx_issue_cmd(adev, ACX1xx_CMD_STOP_SCAN, NULL, 0);
- clear_bit(ACX_FLAG_SCANNING, &adev->flags);
- }