aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-07-23 14:21:26 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-07-23 14:21:26 +0000
commitd219e885a5eed7744f667e40a8a4951cae917530 (patch)
treeea28327bcbc98c7a98dc91b33ddc27b239c1b321 /package/kernel/Makefile
parent6d8578a5d32ab4a511c9b4da39ace4f8dcd3a778 (diff)
downloadupstream-d219e885a5eed7744f667e40a8a4951cae917530.tar.gz
upstream-d219e885a5eed7744f667e40a8a4951cae917530.tar.bz2
upstream-d219e885a5eed7744f667e40a8a4951cae917530.zip
bugfixes for the kernel module packaging
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@4236 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/Makefile')
-rw-r--r--package/kernel/Makefile16
1 files changed, 7 insertions, 9 deletions
diff --git a/package/kernel/Makefile b/package/kernel/Makefile
index 39978ab9f1..c977501e08 100644
--- a/package/kernel/Makefile
+++ b/package/kernel/Makefile
@@ -60,10 +60,6 @@ define KernelPackage
$(eval $(call KernelPackage/$(1)))
$(eval $(call KernelPackage/$(1)/$(KERNEL)))
- ifneq ($(findstring m,$(KCONFIG)),m)
- CONFIG_PACKAGE_kmod-$(1):=
- endif
-
define Package/kmod-$(1)
TITLE:=$(TITLE)
SECTION:=kernel
@@ -75,11 +71,13 @@ define KernelPackage
$(call KernelPackage/$(1)/$(KERNEL))
endef
- define Package/kmod-$(1)/install
- mkdir -p $$(1)/lib/modules/$(LINUX_VERSION)
- $(CP) $(FILES) $$(1)/lib/modules/$(LINUX_VERSION)/
- $(call ModuleAutoLoad,$(1),$$(1),$(AUTOLOAD))
- endef
+ ifeq ($(findstring m,$(KCONFIG)),m)
+ define Package/kmod-$(1)/install
+ mkdir -p $$(1)/lib/modules/$(LINUX_VERSION)
+ $(CP) $$(FILES) $$(1)/lib/modules/$(LINUX_VERSION)/
+ $(call ModuleAutoLoad,$(1),$$(1),$(AUTOLOAD))
+ endef
+ endif
$$(eval $$(call BuildPackage,kmod-$(1)))
endef