aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-06-07 23:59:04 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-06-07 23:59:04 +0000
commit0a58a0f00e8fc468339052d90dce4f3ef8361837 (patch)
treee729abf7b4d3fdcd056cd7b07d586a3739c08c7d /package/kernel.mk
parent435bd1f20adba3da6b2e8ee426947bc7d3d126fd (diff)
downloadupstream-0a58a0f00e8fc468339052d90dce4f3ef8361837.tar.gz
upstream-0a58a0f00e8fc468339052d90dce4f3ef8361837.tar.bz2
upstream-0a58a0f00e8fc468339052d90dce4f3ef8361837.zip
make ramdisk support generic, some cleanups
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@3911 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel.mk')
-rw-r--r--package/kernel.mk5
1 files changed, 4 insertions, 1 deletions
diff --git a/package/kernel.mk b/package/kernel.mk
index def66437c6..39f9cc0c9c 100644
--- a/package/kernel.mk
+++ b/package/kernel.mk
@@ -20,7 +20,10 @@ LINUX_KARCH:=$(shell echo $(ARCH) | sed -e 's/i[3-9]86/i386/' \
)
KERNEL_BUILD_DIR:=$(BUILD_DIR)/linux-$(KERNEL)-$(BOARD)
-LINUX_DIR := $(KERNEL_BUILD_DIR)/linux-$(LINUX_VERSION)
+ifeq ($(LINUX_NAME),)
+LINUX_NAME:=linux-$(LINUX_VERSION)
+endif
+LINUX_DIR := $(KERNEL_BUILD_DIR)/$(LINUX_NAME)
KMOD_BUILD_DIR := $(KERNEL_BUILD_DIR)/linux-modules
MODULES_DIR := $(KERNEL_BUILD_DIR)/modules/$(MODULES_SUBDIR)