aboutsummaryrefslogtreecommitdiffstats
path: root/package/iw
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2011-05-22 12:02:35 +0000
committerJo-Philipp Wich <jow@openwrt.org>2011-05-22 12:02:35 +0000
commit1df56fb1e5a0aa5fecc0abc6c06e20f9035737b5 (patch)
tree64783916f47a93a029e9ef4b50ef2961b74181a2 /package/iw
parent13597f00248aba5f96c511d4a0b5880b539d6f4f (diff)
downloadupstream-1df56fb1e5a0aa5fecc0abc6c06e20f9035737b5.tar.gz
upstream-1df56fb1e5a0aa5fecc0abc6c06e20f9035737b5.tar.bz2
upstream-1df56fb1e5a0aa5fecc0abc6c06e20f9035737b5.zip
[package] iw: fix calculation of fractional multicast rates like 5.5Mbps due to wrong operator precedence
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@26968 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/iw')
-rw-r--r--package/iw/Makefile4
-rw-r--r--package/iw/patches/110-fix_rate_calculation.patch11
2 files changed, 13 insertions, 2 deletions
diff --git a/package/iw/Makefile b/package/iw/Makefile
index 625e17921b..2b714f8f98 100644
--- a/package/iw/Makefile
+++ b/package/iw/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2007-2009 OpenWrt.org
+# Copyright (C) 2007-2011 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=iw
PKG_VERSION:=0.9.22
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://wireless.kernel.org/download/iw/
diff --git a/package/iw/patches/110-fix_rate_calculation.patch b/package/iw/patches/110-fix_rate_calculation.patch
new file mode 100644
index 0000000000..e7328e39ba
--- /dev/null
+++ b/package/iw/patches/110-fix_rate_calculation.patch
@@ -0,0 +1,11 @@
+--- a/ibss.c
++++ b/ibss.c
+@@ -104,7 +104,7 @@ static int join_ibss(struct nl80211_stat
+ if (*end != '\0')
+ return 1;
+
+- NLA_PUT_U32(msg, NL80211_ATTR_MCAST_RATE, (int) rate * 10);
++ NLA_PUT_U32(msg, NL80211_ATTR_MCAST_RATE, (int)(rate * 10));
+ argv++;
+ argc--;
+ }