aboutsummaryrefslogtreecommitdiffstats
path: root/package/iptables
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-10-09 17:47:55 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-10-09 17:47:55 +0000
commitf60dc2e1f8646ddc28738e6fd041e3577d193814 (patch)
treec86679b618329c656e0205540efc7ee322dd36ae /package/iptables
parent5b17be689c3b387431b83ffb382e14c17c955d08 (diff)
downloadupstream-f60dc2e1f8646ddc28738e6fd041e3577d193814.tar.gz
upstream-f60dc2e1f8646ddc28738e6fd041e3577d193814.tar.bz2
upstream-f60dc2e1f8646ddc28738e6fd041e3577d193814.zip
[package] iptables: don't use /bin/bash in autogen.sh, breaks FreeBSD. Also move autogen.sh invocation to Build/Configure
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@23369 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/iptables')
-rw-r--r--package/iptables/Makefile4
-rw-r--r--package/iptables/patches/100-bash-location.patch16
2 files changed, 18 insertions, 2 deletions
diff --git a/package/iptables/Makefile b/package/iptables/Makefile
index 8609b6d7c4..e637771871 100644
--- a/package/iptables/Makefile
+++ b/package/iptables/Makefile
@@ -305,9 +305,9 @@ MAKE_FLAGS := \
KERNEL_DIR="$(LINUX_DIR)" PREFIX=/usr \
KBUILD_OUTPUT="$(LINUX_DIR)" \
-define Build/Prepare
-$(call Build/Prepare/Default)
+define Build/Configure
(cd $(PKG_BUILD_DIR); ./autogen.sh)
+$(call Build/Configure/Default)
endef
define Build/InstallDev
diff --git a/package/iptables/patches/100-bash-location.patch b/package/iptables/patches/100-bash-location.patch
new file mode 100644
index 0000000000..818246e76b
--- /dev/null
+++ b/package/iptables/patches/100-bash-location.patch
@@ -0,0 +1,16 @@
+--- a/autogen.sh
++++ b/autogen.sh
+@@ -1,4 +1,4 @@
+-#!/bin/bash
++#!/usr/bin/env bash
+
+ autoreconf -fi;
+ rm -Rf autom4te*.cache;
+--- a/iptables-apply
++++ b/iptables-apply
+@@ -1,4 +1,4 @@
+-#!/bin/bash
++#!/usr/bin/env bash
+ #
+ # iptables-apply -- a safer way to update iptables remotely
+ #