aboutsummaryrefslogtreecommitdiffstats
path: root/package/iptables
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2011-07-17 15:01:07 +0000
committerJo-Philipp Wich <jow@openwrt.org>2011-07-17 15:01:07 +0000
commitede00d3c69cb569229ee2455d00c2f18ab448654 (patch)
treedb73877358bed24e0702bcea6430d75469c2f869 /package/iptables
parent9dd5b8019edbadf0d42ea8e32f2b8643e766115a (diff)
downloadupstream-ede00d3c69cb569229ee2455d00c2f18ab448654.tar.gz
upstream-ede00d3c69cb569229ee2455d00c2f18ab448654.tar.bz2
upstream-ede00d3c69cb569229ee2455d00c2f18ab448654.zip
[package] iptables: fix redundant binaries in iptables-utils & ip6tables-utils (#9691)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27646 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/iptables')
-rw-r--r--package/iptables/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/package/iptables/Makefile b/package/iptables/Makefile
index 581c0fcdc4..b1ae19db17 100644
--- a/package/iptables/Makefile
+++ b/package/iptables/Makefile
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=iptables
PKG_VERSION:=1.4.10
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_MD5SUM:=f382fe693f0b59d87bd47bea65eca198
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -380,7 +380,9 @@ endef
define Package/iptables-utils/install
$(INSTALL_DIR) $(1)/usr/sbin
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/iptables-{save,restore} $(1)/usr/sbin/
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/iptables-multi $(1)/usr/sbin/
+ $(LN) iptables-multi $(1)/usr/sbin/iptables-save
+ $(LN) iptables-multi $(1)/usr/sbin/iptables-restore
endef
define Package/ip6tables/install
@@ -394,7 +396,9 @@ endef
define Package/ip6tables-utils/install
$(INSTALL_DIR) $(1)/usr/sbin
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/ip6tables-{save,restore} $(1)/usr/sbin/
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/ip6tables-multi $(1)/usr/sbin/
+ $(LN) ip6tables-multi $(1)/usr/sbin/ip6tables-save
+ $(LN) ip6tables-multi $(1)/usr/sbin/ip6tables-restore
endef
define Package/libiptc/install