aboutsummaryrefslogtreecommitdiffstats
path: root/package/iptables
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2011-02-21 09:27:32 +0000
committerImre Kaloz <kaloz@openwrt.org>2011-02-21 09:27:32 +0000
commite19628375d9500733e9c9db769c33fdfbc6ecc76 (patch)
tree24030d049f9e299554022df9b8d9f5cca3166f86 /package/iptables
parent06e75278759bb8f917a40639980f406b6f6271f8 (diff)
downloadupstream-e19628375d9500733e9c9db769c33fdfbc6ecc76.tar.gz
upstream-e19628375d9500733e9c9db769c33fdfbc6ecc76.tar.bz2
upstream-e19628375d9500733e9c9db769c33fdfbc6ecc76.zip
[package/iptables]: as [25641] removed kernel IMQ support, remove it from iptables as well
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@25646 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/iptables')
-rw-r--r--package/iptables/Makefile12
-rw-r--r--package/iptables/patches/005-imq.patch124
2 files changed, 0 insertions, 136 deletions
diff --git a/package/iptables/Makefile b/package/iptables/Makefile
index 597f2bd300..586576a1ea 100644
--- a/package/iptables/Makefile
+++ b/package/iptables/Makefile
@@ -99,17 +99,6 @@ Includes:
- libipt_layer7
endef
-define Package/iptables-mod-imq
-$(call Package/iptables/Module, +kmod-ipt-imq)
- TITLE:=IMQ support
-endef
-
-define Package/iptables-mod-imq/description
-iptables extension for IMQ support.
-Includes:
-- libipt_IMQ
-endef
-
define Package/iptables-mod-ipopt
$(call Package/iptables/Module, +kmod-ipt-ipopt)
TITLE:=IP/Packet option extensions
@@ -400,7 +389,6 @@ $(eval $(call BuildPlugin,iptables-mod-conntrack,$(IPT_CONNTRACK-m)))
$(eval $(call BuildPlugin,iptables-mod-conntrack-extra,$(IPT_CONNTRACK_EXTRA-m)))
$(eval $(call BuildPlugin,iptables-mod-extra,$(IPT_EXTRA-m)))
$(eval $(call BuildPlugin,iptables-mod-filter,$(IPT_FILTER-m),$(L7_INSTALL)))
-$(eval $(call BuildPlugin,iptables-mod-imq,$(IPT_IMQ-m)))
$(eval $(call BuildPlugin,iptables-mod-ipopt,$(IPT_IPOPT-m)))
$(eval $(call BuildPlugin,iptables-mod-ipsec,$(IPT_IPSEC-m)))
$(eval $(call BuildPlugin,iptables-mod-ipset,ipt_set ipt_SET))
diff --git a/package/iptables/patches/005-imq.patch b/package/iptables/patches/005-imq.patch
deleted file mode 100644
index 9e4d6277b5..0000000000
--- a/package/iptables/patches/005-imq.patch
+++ /dev/null
@@ -1,124 +0,0 @@
---- /dev/null
-+++ b/extensions/.IMQ-testx
-@@ -0,0 +1,3 @@
-+#!/bin/sh
-+# True if IMQ target patch is applied.
-+[ -f $KERNEL_DIR/include/linux/netfilter/xt_IMQ.h ] && echo IMQ
---- /dev/null
-+++ b/extensions/libxt_IMQ.c
-@@ -0,0 +1,103 @@
-+/* Shared library add-on to iptables to add IMQ target support. */
-+#include <stdio.h>
-+#include <string.h>
-+#include <stdlib.h>
-+#include <getopt.h>
-+
-+#include <xtables.h>
-+#include <linux/netfilter/x_tables.h>
-+#include <linux/netfilter/xt_IMQ.h>
-+
-+/* Function which prints out usage message. */
-+static void IMQ_help(void)
-+{
-+ printf(
-+"IMQ target v%s options:\n"
-+" --todev <N> enqueue to imq<N>, defaults to 0\n",
-+XTABLES_VERSION);
-+}
-+
-+static struct option IMQ_opts[] = {
-+ { "todev", 1, 0, '1' },
-+ { 0 }
-+};
-+
-+/* Initialize the target. */
-+static void IMQ_init(struct xt_entry_target *t)
-+{
-+ struct xt_imq_info *mr = (struct xt_imq_info*)t->data;
-+
-+ mr->todev = 0;
-+}
-+
-+/* Function which parses command options; returns true if it
-+ ate an option */
-+static int IMQ_parse(int c, char **argv, int invert, unsigned int *flags,
-+ const void *entry, struct xt_entry_target **target)
-+{
-+ struct xt_imq_info *mr = (struct xt_imq_info*)(*target)->data;
-+
-+ switch(c) {
-+ case '1':
-+ if (xtables_check_inverse(optarg, &invert, NULL, 0, argv))
-+ xtables_error(PARAMETER_PROBLEM,
-+ "Unexpected `!' after --todev");
-+ mr->todev=atoi(optarg);
-+ break;
-+ default:
-+ return 0;
-+ }
-+ return 1;
-+}
-+
-+/* Prints out the targinfo. */
-+static void IMQ_print(const void *ip,
-+ const struct xt_entry_target *target,
-+ int numeric)
-+{
-+ struct xt_imq_info *mr = (struct xt_imq_info*)target->data;
-+
-+ printf("IMQ: todev %u ", mr->todev);
-+}
-+
-+/* Saves the union ipt_targinfo in parsable form to stdout. */
-+static void IMQ_save(const void *ip, const struct xt_entry_target *target)
-+{
-+ struct xt_imq_info *mr = (struct xt_imq_info*)target->data;
-+
-+ printf("--todev %u", mr->todev);
-+}
-+
-+static struct xtables_target imq_target = {
-+ .name = "IMQ",
-+ .version = XTABLES_VERSION,
-+ .family = NFPROTO_IPV4,
-+ .size = XT_ALIGN(sizeof(struct xt_imq_info)),
-+ .userspacesize = XT_ALIGN(sizeof(struct xt_imq_info)),
-+ .help = IMQ_help,
-+ .init = IMQ_init,
-+ .parse = IMQ_parse,
-+ .print = IMQ_print,
-+ .save = IMQ_save,
-+ .extra_opts = IMQ_opts,
-+};
-+
-+static struct xtables_target imq_target6 = {
-+ .name = "IMQ",
-+ .version = XTABLES_VERSION,
-+ .family = NFPROTO_IPV6,
-+ .size = XT_ALIGN(sizeof(struct xt_imq_info)),
-+ .userspacesize = XT_ALIGN(sizeof(struct xt_imq_info)),
-+ .help = IMQ_help,
-+ .init = IMQ_init,
-+ .parse = IMQ_parse,
-+ .print = IMQ_print,
-+ .save = IMQ_save,
-+ .extra_opts = IMQ_opts,
-+};
-+
-+void _init(void)
-+{
-+ xtables_register_target(&imq_target);
-+ xtables_register_target(&imq_target6);
-+}
---- /dev/null
-+++ b/include/linux/netfilter/xt_IMQ.h
-@@ -0,0 +1,9 @@
-+#ifndef _XT_IMQ_H
-+#define _XT_IMQ_H
-+
-+struct xt_imq_info {
-+ unsigned int todev; /* target imq device */
-+};
-+
-+#endif /* _XT_IMQ_H */
-+