aboutsummaryrefslogtreecommitdiffstats
path: root/package/iptables
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2013-06-05 10:12:51 +0000
committerJo-Philipp Wich <jow@openwrt.org>2013-06-05 10:12:51 +0000
commitbafd98a883e6ff54bd1be087c848f876fdc6fcf8 (patch)
tree517704e153de23cdeed6d0dbd1a8e532e9ae59bd /package/iptables
parentf0fc8f5100ff606038a185766df3256eaf501f0f (diff)
downloadupstream-bafd98a883e6ff54bd1be087c848f876fdc6fcf8.tar.gz
upstream-bafd98a883e6ff54bd1be087c848f876fdc6fcf8.tar.bz2
upstream-bafd98a883e6ff54bd1be087c848f876fdc6fcf8.zip
AA: iptables: backport r35898 (#13649)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/attitude_adjustment@36853 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/iptables')
-rw-r--r--package/iptables/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/iptables/Makefile b/package/iptables/Makefile
index ff7d428215..45a1c8766f 100644
--- a/package/iptables/Makefile
+++ b/package/iptables/Makefile
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=iptables
PKG_VERSION:=1.4.10
-PKG_RELEASE:=4
+PKG_RELEASE:=5
PKG_MD5SUM:=f382fe693f0b59d87bd47bea65eca198
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -364,7 +364,7 @@ MAKE_FLAGS := \
COPT_FLAGS="$(TARGET_CFLAGS)" \
KERNEL_DIR="$(LINUX_DIR)/user_headers/" PREFIX=/usr \
KBUILD_OUTPUT="$(LINUX_DIR)" \
- BUILTIN_MODULES="$(patsubst ipt_%,%,$(patsubst xt_%,%,$(IPT_BUILTIN) $(IPT_CONNTRACK-m) $(IPT_NAT-m)))"
+ BUILTIN_MODULES="$(patsubst ip6t_%,%,$(patsubst ipt_%,%,$(patsubst xt_%,%,$(IPT_BUILTIN) $(IPT_CONNTRACK-m) $(IPT_NAT-m))))"
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include
@@ -436,7 +436,7 @@ endef
define BuildPlugin
define Package/$(1)/install
$(INSTALL_DIR) $$(1)/usr/lib/iptables
- for m in $(patsubst xt_%,ipt_%,$(2)) $(patsubst ipt_%,xt_%,$(2)); do \
+ for m in $(patsubst xt_%,ipt_%,$(2)) $(patsubst ipt_%,xt_%,$(2)) $(patsubst xt_%,ip6t_%,$(2)) $(patsubst ip6t_%,xt_%,$(2)); do \
if [ -f $(PKG_INSTALL_DIR)/usr/lib/iptables/lib$$$$$$$${m}.so ]; then \
$(CP) $(PKG_INSTALL_DIR)/usr/lib/iptables/lib$$$$$$$${m}.so $$(1)/usr/lib/iptables/ ; \
fi; \