aboutsummaryrefslogtreecommitdiffstats
path: root/package/iptables
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-06-22 22:39:22 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-06-22 22:39:22 +0000
commit881cdcaf368e083f4a8c191ac9d5b8bdc0822f42 (patch)
treeb6defe2fc55d001fb2e3eaaa192c96a6a6c0315f /package/iptables
parent8577f40a43e051a4ba477790a0af9cd941be9e8a (diff)
downloadupstream-881cdcaf368e083f4a8c191ac9d5b8bdc0822f42.tar.gz
upstream-881cdcaf368e083f4a8c191ac9d5b8bdc0822f42.tar.bz2
upstream-881cdcaf368e083f4a8c191ac9d5b8bdc0822f42.zip
[netfilter] package TPROXY target and module infrastructure
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@21883 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/iptables')
-rw-r--r--package/iptables/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/package/iptables/Makefile b/package/iptables/Makefile
index d8698c5de6..b37a66fd3f 100644
--- a/package/iptables/Makefile
+++ b/package/iptables/Makefile
@@ -214,6 +214,19 @@ Includes:
- libipt_recent
endef
+define Package/iptables-mod-tproxy
+$(call Package/iptables/Module, +kmod-ipt-tproxy)
+ TITLE:=Transparent proxy iptables extensions
+endef
+
+define Package/iptables-mod-tproxy/description
+Transparent proxy iptables extensions.
+Includes:
+- libxt_socket
+- libxt_TPROXY
+endef
+
+
define Package/iptables-utils
$(call Package/iptables/Module, )
TITLE:=iptables save and restore utilities
@@ -380,6 +393,7 @@ $(eval $(call BuildPlugin,iptables-mod-nat,$(IPT_NAT-m)))
$(eval $(call BuildPlugin,iptables-mod-nat-extra,$(IPT_NAT_EXTRA-m)))
$(eval $(call BuildPlugin,iptables-mod-iprange,$(IPT_IPRANGE-m)))
$(eval $(call BuildPlugin,iptables-mod-ulog,$(IPT_ULOG-m)))
+$(eval $(call BuildPlugin,iptables-mod-tproxy,$(IPT_TPROXY-m)))
$(eval $(call BuildPackage,ip6tables))
$(eval $(call BuildPackage,ip6tables-utils))
$(eval $(call BuildPackage,libiptc))