aboutsummaryrefslogtreecommitdiffstats
path: root/package/iptables
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-05-03 09:43:10 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-05-03 09:43:10 +0000
commit7f4625bd8ca07fbbfeeb5540796466bbe6e6cbb3 (patch)
treea13d43697482a31003c24f232dcb3d174bd4bb43 /package/iptables
parent59ba22536d502e4f2afdc22ba3e675da1360210e (diff)
downloadupstream-7f4625bd8ca07fbbfeeb5540796466bbe6e6cbb3.tar.gz
upstream-7f4625bd8ca07fbbfeeb5540796466bbe6e6cbb3.tar.bz2
upstream-7f4625bd8ca07fbbfeeb5540796466bbe6e6cbb3.zip
Fix iptables abuse of kernel header files. Use exported headers instead.
[juhosg: export xt_layer7.h for all kernel versions] Signed-off-by: David Woodhouse <David.Woodhouse@intel.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31566 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/iptables')
-rw-r--r--package/iptables/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/package/iptables/Makefile b/package/iptables/Makefile
index 026df266ba..ff7d428215 100644
--- a/package/iptables/Makefile
+++ b/package/iptables/Makefile
@@ -343,26 +343,26 @@ endef
TARGET_CPPFLAGS := \
-I$(PKG_BUILD_DIR)/include \
- -I$(LINUX_DIR)/arch/$(LINUX_KARCH)/include \
+ -I$(LINUX_DIR)/user_headers/include \
$(TARGET_CPPFLAGS)
TARGET_CFLAGS += \
-I$(PKG_BUILD_DIR)/include \
- -I$(LINUX_DIR)/arch/$(LINUX_KARCH)/include
+ -I$(LINUX_DIR)/user_headers/include
CONFIGURE_ARGS += \
--enable-shared \
--enable-devel \
$(if $(CONFIG_IPV6),--enable-ipv6,--disable-ipv6) \
--enable-libipq \
- --with-kernel="$(LINUX_DIR)" \
+ --with-kernel="$(LINUX_DIR)/user_headers" \
--with-xtlibdir=/usr/lib/iptables \
--enable-static
MAKE_FLAGS := \
$(TARGET_CONFIGURE_OPTS) \
COPT_FLAGS="$(TARGET_CFLAGS)" \
- KERNEL_DIR="$(LINUX_DIR)" PREFIX=/usr \
+ KERNEL_DIR="$(LINUX_DIR)/user_headers/" PREFIX=/usr \
KBUILD_OUTPUT="$(LINUX_DIR)" \
BUILTIN_MODULES="$(patsubst ipt_%,%,$(patsubst xt_%,%,$(IPT_BUILTIN) $(IPT_CONNTRACK-m) $(IPT_NAT-m)))"