aboutsummaryrefslogtreecommitdiffstats
path: root/package/iptables
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2011-08-11 21:26:44 +0000
committerJo-Philipp Wich <jow@openwrt.org>2011-08-11 21:26:44 +0000
commit6f64e87d8ad1486ff0dfea4908a88b1a9db6cc89 (patch)
tree57d4f5eab104b4c69233f90e4f26eca05aef3132 /package/iptables
parent5331e1bdc4005f5afcf1bbf1c0b31aa5ed73186e (diff)
downloadupstream-6f64e87d8ad1486ff0dfea4908a88b1a9db6cc89.tar.gz
upstream-6f64e87d8ad1486ff0dfea4908a88b1a9db6cc89.tar.bz2
upstream-6f64e87d8ad1486ff0dfea4908a88b1a9db6cc89.zip
[package] iptables: drop iptables-utils and ip6tables-utils, ship needed symlinks in iptables and ip6tables packages (#9691)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27961 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/iptables')
-rw-r--r--package/iptables/Makefile34
1 files changed, 5 insertions, 29 deletions
diff --git a/package/iptables/Makefile b/package/iptables/Makefile
index 1286062ce7..67dedca38f 100644
--- a/package/iptables/Makefile
+++ b/package/iptables/Makefile
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=iptables
PKG_VERSION:=1.4.10
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_MD5SUM:=f382fe693f0b59d87bd47bea65eca198
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -332,11 +332,6 @@ U32 iptables extensions.
endef
-define Package/iptables-utils
-$(call Package/iptables/Module, )
- TITLE:=iptables save and restore utilities
-endef
-
define Package/ip6tables
$(call Package/iptables/Default)
DEPENDS:=+kmod-ip6tables +libip6tc +libxtables
@@ -345,13 +340,6 @@ $(call Package/iptables/Default)
MENU:=1
endef
-define Package/ip6tables-utils
-$(call Package/iptables/Default)
- DEPENDS:=ip6tables
- CATEGORY:=IPv6
- TITLE:=ip6tables save and restore utilities
-endef
-
define Package/libiptc
$(call Package/iptables/Default)
SECTION:=libs
@@ -438,6 +426,8 @@ endef
define Package/iptables/install
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/iptables $(1)/usr/sbin/
+ $(LN) iptables $(1)/usr/sbin/iptables-save
+ $(LN) iptables $(1)/usr/sbin/iptables-restore
$(INSTALL_DIR) $(1)/usr/lib/iptables
(cd $(PKG_INSTALL_DIR)/usr/lib/iptables ; \
for m in $(patsubst xt_%,ipt_%,$(IPT_BUILTIN)) $(patsubst ipt_%,xt_%,$(IPT_BUILTIN)); do \
@@ -448,29 +438,17 @@ define Package/iptables/install
)
endef
-define Package/iptables-utils/install
- $(INSTALL_DIR) $(1)/usr/sbin
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/iptables-multi $(1)/usr/sbin/
- $(LN) iptables-multi $(1)/usr/sbin/iptables-save
- $(LN) iptables-multi $(1)/usr/sbin/iptables-restore
-endef
-
define Package/ip6tables/install
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/ip6tables $(1)/usr/sbin/
+ $(LN) ip6tables $(1)/usr/sbin/ip6tables-save
+ $(LN) ip6tables $(1)/usr/sbin/ip6tables-restore
$(INSTALL_DIR) $(1)/usr/lib/iptables
(cd $(PKG_INSTALL_DIR)/usr/lib/iptables ; \
$(CP) libip6t_*.so $(1)/usr/lib/iptables/ \
)
endef
-define Package/ip6tables-utils/install
- $(INSTALL_DIR) $(1)/usr/sbin
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/ip6tables-multi $(1)/usr/sbin/
- $(LN) ip6tables-multi $(1)/usr/sbin/ip6tables-save
- $(LN) ip6tables-multi $(1)/usr/sbin/ip6tables-restore
-endef
-
define Package/libiptc/install
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libiptc.so* $(1)/usr/lib/
@@ -516,7 +494,6 @@ L7_INSTALL:=\
$(eval $(call BuildPackage,iptables))
-$(eval $(call BuildPackage,iptables-utils))
$(eval $(call BuildPlugin,iptables-mod-conntrack,$(IPT_CONNTRACK-m)))
$(eval $(call BuildPlugin,iptables-mod-conntrack-extra,$(IPT_CONNTRACK_EXTRA-m)))
$(eval $(call BuildPlugin,iptables-mod-extra,$(IPT_EXTRA-m)))
@@ -534,7 +511,6 @@ $(eval $(call BuildPlugin,iptables-mod-tproxy,$(IPT_TPROXY-m)))
$(eval $(call BuildPlugin,iptables-mod-tee,$(IPT_TEE-m)))
$(eval $(call BuildPlugin,iptables-mod-u32,$(IPT_U32-m)))
$(eval $(call BuildPackage,ip6tables))
-$(eval $(call BuildPackage,ip6tables-utils))
$(eval $(call BuildPackage,libiptc))
$(eval $(call BuildPackage,libip4tc))
$(eval $(call BuildPackage,libip6tc))