aboutsummaryrefslogtreecommitdiffstats
path: root/package/iptables
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2010-04-20 16:18:03 +0000
committerFlorian Fainelli <florian@openwrt.org>2010-04-20 16:18:03 +0000
commit6edd065384aff0d9b7aba8205d5df441d9b21e29 (patch)
treed123263d339f17543d36133c47fd8901a2432dff /package/iptables
parent8ec7ce619a8779cd89be9d6c253fda6fee763e3e (diff)
downloadupstream-6edd065384aff0d9b7aba8205d5df441d9b21e29.tar.gz
upstream-6edd065384aff0d9b7aba8205d5df441d9b21e29.tar.bz2
upstream-6edd065384aff0d9b7aba8205d5df441d9b21e29.zip
[package] fix iptables cflags to include architecture specific asm includes
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@21045 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/iptables')
-rw-r--r--package/iptables/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/iptables/Makefile b/package/iptables/Makefile
index e97cfbbcad..f683331ffa 100644
--- a/package/iptables/Makefile
+++ b/package/iptables/Makefile
@@ -254,6 +254,10 @@ TARGET_CPPFLAGS := \
-I$(LINUX_DIR)/arch/$(LINUX_KARCH)/include \
$(TARGET_CPPFLAGS)
+TARGET_CFLAGS += \
+ -I$(PKG_BUILD_DIR)/include \
+ -I$(LINUX_DIR)/arch/$(LINUX_KARCH)/include
+
CONFIGURE_ARGS += \
--enable-shared \
--enable-devel \