aboutsummaryrefslogtreecommitdiffstats
path: root/package/iptables
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2011-07-05 12:40:59 +0000
committerFlorian Fainelli <florian@openwrt.org>2011-07-05 12:40:59 +0000
commit6d1af493fb0d17f8f0eb599e218aa04f02e2ef32 (patch)
tree49475100df37c4b544f0e94192928c96cd85b518 /package/iptables
parent4a99e893c2bd618edfeee0bdc3d6291766dfca49 (diff)
downloadupstream-6d1af493fb0d17f8f0eb599e218aa04f02e2ef32.tar.gz
upstream-6d1af493fb0d17f8f0eb599e218aa04f02e2ef32.tar.bz2
upstream-6d1af493fb0d17f8f0eb599e218aa04f02e2ef32.zip
[package] iptables: add iptables-mod-led (#9400)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27460 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/iptables')
-rw-r--r--package/iptables/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/package/iptables/Makefile b/package/iptables/Makefile
index 61739d3551..581c0fcdc4 100644
--- a/package/iptables/Makefile
+++ b/package/iptables/Makefile
@@ -217,6 +217,17 @@ Includes:
- libipt_recent
endef
+define Package/iptables-mod-led
+$(call Package/iptables/Module, +kmod-ipt-led)
+ TITLE:=LED trigger iptables extension
+endef
+
+define Package/iptables-mod-led/description
+iptables extension for triggering a LED.
+Includes:
+- libxt_LED
+endef
+
define Package/iptables-mod-tproxy
$(call Package/iptables/Module, +kmod-ipt-tproxy)
TITLE:=Transparent proxy iptables extensions
@@ -444,6 +455,7 @@ $(eval $(call BuildPlugin,iptables-mod-nat-extra,$(IPT_NAT_EXTRA-m)))
$(eval $(call BuildPlugin,iptables-mod-iprange,$(IPT_IPRANGE-m)))
$(eval $(call BuildPlugin,iptables-mod-ulog,$(IPT_ULOG-m)))
$(eval $(call BuildPlugin,iptables-mod-hashlimit,$(IPT_HASHLIMIT-m)))
+$(eval $(call BuildPlugin,iptables-mod-led,$(IPT_LED-m)))
$(eval $(call BuildPlugin,iptables-mod-tproxy,$(IPT_TPROXY-m)))
$(eval $(call BuildPlugin,iptables-mod-tee,$(IPT_TEE-m)))
$(eval $(call BuildPlugin,iptables-mod-u32,$(IPT_U32-m)))