aboutsummaryrefslogtreecommitdiffstats
path: root/package/iptables
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2011-05-24 08:14:29 +0000
committerJo-Philipp Wich <jow@openwrt.org>2011-05-24 08:14:29 +0000
commit55283cbc90896ca72485ce1f754d101f93bde117 (patch)
treed0f33910d65533bd463e4d86f541c530f8ecedf6 /package/iptables
parent740d9edf5a06ae662c34b9a9eaeeaba87afc0a3b (diff)
downloadupstream-55283cbc90896ca72485ce1f754d101f93bde117.tar.gz
upstream-55283cbc90896ca72485ce1f754d101f93bde117.tar.bz2
upstream-55283cbc90896ca72485ce1f754d101f93bde117.zip
[netfilter] package u32 match and TEE target, patches by Maxim Uvarov
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@26977 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/iptables')
-rw-r--r--package/iptables/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/package/iptables/Makefile b/package/iptables/Makefile
index f0f96f0351..61739d3551 100644
--- a/package/iptables/Makefile
+++ b/package/iptables/Makefile
@@ -229,6 +229,27 @@ Includes:
- libxt_TPROXY
endef
+define Package/iptables-mod-tee
+$(call Package/iptables/Module, +kmod-ipt-tee)
+ TITLE:=TEE iptables extensions
+endef
+
+define Package/iptables-mod-tee/description
+TEE iptables extensions.
+Includes:
+- libxt_TEE
+endef
+
+define Package/iptables-mod-u32
+$(call Package/iptables/Module, +kmod-ipt-u32)
+ TITLE:=U32 iptables extensions
+endef
+
+define Package/iptables-mod-u32/description
+U32 iptables extensions.
+Includes:
+- libxt_u32
+endef
define Package/iptables-utils
$(call Package/iptables/Module, )
@@ -424,6 +445,8 @@ $(eval $(call BuildPlugin,iptables-mod-iprange,$(IPT_IPRANGE-m)))
$(eval $(call BuildPlugin,iptables-mod-ulog,$(IPT_ULOG-m)))
$(eval $(call BuildPlugin,iptables-mod-hashlimit,$(IPT_HASHLIMIT-m)))
$(eval $(call BuildPlugin,iptables-mod-tproxy,$(IPT_TPROXY-m)))
+$(eval $(call BuildPlugin,iptables-mod-tee,$(IPT_TEE-m)))
+$(eval $(call BuildPlugin,iptables-mod-u32,$(IPT_U32-m)))
$(eval $(call BuildPackage,ip6tables))
$(eval $(call BuildPackage,ip6tables-utils))
$(eval $(call BuildPackage,libiptc))