aboutsummaryrefslogtreecommitdiffstats
path: root/package/iptables/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-04-05 02:09:22 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-04-05 02:09:22 +0000
commite1b417ee76bd97a05854f4304cef3f73e9da633b (patch)
treef5913675e5868c535c007efb3e09a01ce6890287 /package/iptables/Makefile
parent42269e22a8b817e1e6bc2c9cbb2f03df31221458 (diff)
downloadupstream-e1b417ee76bd97a05854f4304cef3f73e9da633b.tar.gz
upstream-e1b417ee76bd97a05854f4304cef3f73e9da633b.tar.bz2
upstream-e1b417ee76bd97a05854f4304cef3f73e9da633b.zip
large init script cleanup and merge of whiterussian changes, new dnsmasq config handling
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@3588 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/iptables/Makefile')
-rw-r--r--package/iptables/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/package/iptables/Makefile b/package/iptables/Makefile
index 298a9a9e0f..f16ac8be48 100644
--- a/package/iptables/Makefile
+++ b/package/iptables/Makefile
@@ -72,6 +72,13 @@ $(PKG_BUILD_DIR)/.built:
touch $@
$(IPKG_IPTABLES):
+ install -d -m0755 $(IDIR_IPTABLES)/etc/config
+ install -m0644 ./files/firewall.config $(IDIR_IPTABLES)/etc/config/firewall
+ install -d -m0755 $(IDIR_IPTABLES)/etc/init.d
+ install -m0755 ./files/firewall.init $(IDIR_IPTABLES)/etc/init.d/S45firewall
+ install -m0755 ./files/firewall.user $(IDIR_IPTABLES)/etc/
+ install -d -m0755 $(IDIR_IPTABLES)/usr/lib
+ install -m0644 ./files/firewall.awk $(IDIR_IPTABLES)/usr/lib
install -d -m0755 $(IDIR_IPTABLES)/usr/sbin
$(CP) $(PKG_INSTALL_DIR)/usr/sbin/iptables $(IDIR_IPTABLES)/usr/sbin/
install -d -m0755 $(IDIR_IPTABLES)/usr/lib/iptables