aboutsummaryrefslogtreecommitdiffstats
path: root/package/ipset
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2009-12-23 09:32:45 +0000
committerNicolas Thill <nico@openwrt.org>2009-12-23 09:32:45 +0000
commit429d4436db41a9726b61eb742af10979617d4b82 (patch)
tree63eb88e6a5ebe45fe5eda387ac3b693bb139b35f /package/ipset
parent5b87800acba5859c763d036e92cda13038b2cff0 (diff)
downloadupstream-429d4436db41a9726b61eb742af10979617d4b82.tar.gz
upstream-429d4436db41a9726b61eb742af10979617d4b82.tar.bz2
upstream-429d4436db41a9726b61eb742af10979617d4b82.zip
[package] ipset: use a common DEPENDS for both ipset and kmod-ipset packages
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18902 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/ipset')
-rw-r--r--package/ipset/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/package/ipset/Makefile b/package/ipset/Makefile
index b2095d668f..e7870c5585 100644
--- a/package/ipset/Makefile
+++ b/package/ipset/Makefile
@@ -18,10 +18,15 @@ PKG_MD5SUM:=d104007fdf5ea64fef774c22b1c0a97b
include $(INCLUDE_DIR)/package.mk
+define Package/ipset/Default
+ DEPENDS:= @LINUX_2_6
+endef
+
define Package/ipset
+$(call Package/ipset/Default)
SECTION:=net
CATEGORY:=Network
- DEPENDS:= @LINUX_2_6 +iptables-mod-ipset +kmod-ipt-ipset
+ DEPENDS+= +iptables-mod-ipset +kmod-ipt-ipset
TITLE:=IPset administration utility
URL:=http://ipset.netfilter.org/
endef
@@ -67,9 +72,10 @@ define Package/ipset/install
endef
define KernelPackage/ipt-ipset
+$(call Package/ipset/Default)
SUBMENU:=Netfilter Extensions
TITLE:=IPset netfilter modules
- DEPENDS:= @LINUX_2_6 kmod-ipt-core
+ DEPENDS+= kmod-ipt-core
FILES:=$(foreach mod,$(IPSET_MODULES),$(PKG_BUILD_DIR)/kernel/$(mod).ko)
AUTOLOAD:=$(call AutoLoad,46,$(IPSET_MODULES))
endef