aboutsummaryrefslogtreecommitdiffstats
path: root/package/ipsec-tools
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2008-08-20 22:00:41 +0000
committerNicolas Thill <nico@openwrt.org>2008-08-20 22:00:41 +0000
commit89124c8a0ab1baeb926108bb8dd503c24a25b75d (patch)
tree27743e0b45f666445f1b7cdb4287364bb008fe70 /package/ipsec-tools
parentd9b755b3dc4f9121ab70b9d816ce813f6038ad6b (diff)
downloadupstream-89124c8a0ab1baeb926108bb8dd503c24a25b75d.tar.gz
upstream-89124c8a0ab1baeb926108bb8dd503c24a25b75d.tar.bz2
upstream-89124c8a0ab1baeb926108bb8dd503c24a25b75d.zip
move more extra packages from ./trunk to ./packages
SVN-Revision: 12359
Diffstat (limited to 'package/ipsec-tools')
-rw-r--r--package/ipsec-tools/Makefile86
-rw-r--r--package/ipsec-tools/patches/001-no_libfl.patch26
-rw-r--r--package/ipsec-tools/patches/002-configure_cppflags_typo.patch26
-rw-r--r--package/ipsec-tools/patches/003-linux_2.6.19_rtnetlink_changes.diff22
4 files changed, 0 insertions, 160 deletions
diff --git a/package/ipsec-tools/Makefile b/package/ipsec-tools/Makefile
deleted file mode 100644
index 0f24ae12ee..0000000000
--- a/package/ipsec-tools/Makefile
+++ /dev/null
@@ -1,86 +0,0 @@
-#
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-# $Id$
-
-include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/kernel.mk
-
-PKG_NAME:=ipsec-tools
-PKG_VERSION:=0.7
-PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=@SF/ipsec-tools
-PKG_MD5SUM:=c0a586924edde35264ecfe94ad1c261f
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/ipsec-tools
- SECTION:=net
- CATEGORY:=Network
- DEPENDS:=@LINUX_2_6 +libopenssl
- TITLE:=IPsec management tools
- URL:=http://ipsec-tools.sourceforge.net/
-endef
-
-CONFIGURE_ARGS += \
- --enable-shared \
- --enable-static \
- --with-kernel-headers="$(LINUX_DIR)/include" \
- --without-readline \
- --with-openssl="$(STAGING_DIR)/usr" \
- --without-libradius \
- --without-libpam \
- --enable-dpd \
- --enable-hybrid \
- --enable-security-context=no \
- --enable-natt \
- --enable-adminport \
- --enable-ipv6
-
-define Build/Configure
- (cd $(PKG_BUILD_DIR); touch \
- configure.ac \
- aclocal.m4 \
- Makefile.in \
- config.h.in \
- configure \
- );
- $(call Build/Configure/Default)
- echo "#undef HAVE_SHADOW_H" >> $(PKG_BUILD_DIR)/config.h
-endef
-
-# override CFLAGS holding "-Werror" that break builds on compile warnings
-define Build/Compile
- $(MAKE) -C $(PKG_BUILD_DIR) \
- DESTDIR="$(PKG_INSTALL_DIR)" \
- CFLAGS="$(TARGET_CFLAGS)" \
- all install
-endef
-
-define Package/ipsec-tools/install
- $(INSTALL_DIR) $(1)/etc
- $(INSTALL_CONF) $(PKG_BUILD_DIR)/src/racoon/samples/racoon.conf $(1)/etc/
- $(SED) 's|@sysconfdir_x@|/etc|g' $(1)/etc/racoon.conf
- $(INSTALL_DIR) $(1)/etc/racoon
- $(INSTALL_CONF) $(PKG_BUILD_DIR)/src/racoon/samples/psk.txt $(1)/etc/racoon/
- $(INSTALL_DIR) $(1)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libipsec.so.* $(1)/usr/lib/
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libracoon.so.* $(1)/usr/lib/
- $(INSTALL_DIR) $(1)/usr/sbin
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/plainrsa-gen $(1)/usr/sbin/
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/racoon $(1)/usr/sbin/
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/racoonctl $(1)/usr/sbin/
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/setkey $(1)/usr/sbin/
-endef
-
-define Package/ipsec-tools/conffiles
-/etc/racoon.conf
-/etc/racoon/psk.txt
-endef
-
-$(eval $(call BuildPackage,ipsec-tools))
diff --git a/package/ipsec-tools/patches/001-no_libfl.patch b/package/ipsec-tools/patches/001-no_libfl.patch
deleted file mode 100644
index 8abc9a07ed..0000000000
--- a/package/ipsec-tools/patches/001-no_libfl.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-Index: ipsec-tools-0.6.6/src/racoon/cftoken.l
-===================================================================
---- ipsec-tools-0.6.6.orig/src/racoon/cftoken.l 2007-06-04 13:22:36.567296208 +0200
-+++ ipsec-tools-0.6.6/src/racoon/cftoken.l 2007-06-04 13:22:36.646284200 +0200
-@@ -105,6 +105,8 @@
- static int incstackp = 0;
-
- static int yy_first_time = 1;
-+
-+int yywrap(void) { return 1; }
- %}
-
- /* common seciton */
-Index: ipsec-tools-0.6.6/src/setkey/token.l
-===================================================================
---- ipsec-tools-0.6.6.orig/src/setkey/token.l 2007-06-04 13:22:36.575294992 +0200
-+++ ipsec-tools-0.6.6/src/setkey/token.l 2007-06-04 13:22:36.646284200 +0200
-@@ -84,6 +84,8 @@
- #ifndef SADB_X_EALG_AESCTR
- #define SADB_X_EALG_AESCTR (-1)
- #endif
-+
-+int yywrap(void) { return 1; }
- %}
-
- /* common section */
diff --git a/package/ipsec-tools/patches/002-configure_cppflags_typo.patch b/package/ipsec-tools/patches/002-configure_cppflags_typo.patch
deleted file mode 100644
index 407c67ecee..0000000000
--- a/package/ipsec-tools/patches/002-configure_cppflags_typo.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-Index: ipsec-tools-0.6.6/configure.ac
-===================================================================
---- ipsec-tools-0.6.6.orig/configure.ac 2007-06-04 13:22:36.540300312 +0200
-+++ ipsec-tools-0.6.6/configure.ac 2007-06-04 13:22:36.841254560 +0200
-@@ -183,7 +183,7 @@
-
- if test "x$crypto_dir" != "x"; then
- LIBS="$LIBS -L${crypto_dir}/lib"
-- CPPFLAGS="-I${crypto_dir}/include $CPPLAGS"
-+ CPPFLAGS="-I${crypto_dir}/include $CPPFLAGS"
- fi
- AC_MSG_CHECKING(openssl version)
-
-Index: ipsec-tools-0.6.6/configure
-===================================================================
---- ipsec-tools-0.6.6.orig/configure 2007-06-04 13:22:36.547299248 +0200
-+++ ipsec-tools-0.6.6/configure 2007-06-04 13:22:36.850253192 +0200
-@@ -23687,7 +23687,7 @@
-
- if test "x$crypto_dir" != "x"; then
- LIBS="$LIBS -L${crypto_dir}/lib"
-- CPPFLAGS="-I${crypto_dir}/include $CPPLAGS"
-+ CPPFLAGS="-I${crypto_dir}/include $CPPFLAGS"
- fi
- echo "$as_me:$LINENO: checking openssl version" >&5
- echo $ECHO_N "checking openssl version... $ECHO_C" >&6
diff --git a/package/ipsec-tools/patches/003-linux_2.6.19_rtnetlink_changes.diff b/package/ipsec-tools/patches/003-linux_2.6.19_rtnetlink_changes.diff
deleted file mode 100644
index 52d092e6ce..0000000000
--- a/package/ipsec-tools/patches/003-linux_2.6.19_rtnetlink_changes.diff
+++ /dev/null
@@ -1,22 +0,0 @@
-Index: ipsec-tools-0.6.6/src/racoon/grabmyaddr.c
-===================================================================
---- ipsec-tools-0.6.6.orig/src/racoon/grabmyaddr.c 2007-06-04 13:22:36.521303200 +0200
-+++ ipsec-tools-0.6.6/src/racoon/grabmyaddr.c 2007-06-04 13:22:37.064220664 +0200
-@@ -77,10 +77,17 @@
- #ifdef __linux__
- #include <linux/types.h>
- #include <linux/rtnetlink.h>
-+#include <linux/version.h>
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,19)
-+# include <linux/if_addr.h>
-+#endif
- #ifndef HAVE_GETIFADDRS
- #define HAVE_GETIFADDRS
- #define NEED_LINUX_GETIFADDRS
- #endif
-+#ifndef IFA_RTA
-+# define IFA_RTA(r) ((struct rtattr*)(((char*)(r)) + NLMSG_ALIGN(sizeof(struct ifaddrmsg))))
-+#endif
- #endif
-
- #ifndef HAVE_GETIFADDRS